WordPress.org

Ready to get started?Download WordPress

Forums

Duplicate Post
"Do not copy these fields" option not working? (9 posts)

  1. snowmoon
    Member
    Posted 2 years ago #

    Hi. I am using the Duplicate Post plugin alongside Permalink Editor. Both plugins are great, except for the following problem.

    The Permalink Editor creates a field called custom_permalink_alias for each post. I do not want this field duplicated and have specified it in the Duplicate Post options. But on duplicating a post, found that it is still being duplicated. Am I doing some wrong? Has anyone used this option successfully?

    Thanks!

    http://wordpress.org/extend/plugins/duplicate-post/

  2. lopo
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    I'll try to install Permalink Editor and see what's wrong.

  3. lopo
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    it works on my test installation. Beware of forgetting the leading underscore: the field are _custom_permalink_alias and _custom_permalink, not custom_permalink_alias.

  4. snowmoon
    Member
    Posted 2 years ago #

    Hi lopo

    Duplicate Post is great and I have been using it for a long time.

    With the latest version of WP and Duplicate Post, I'm noticing this undesirable effect.

    Say someone has commented on my original post and has requested email notification of further comments. When I duplicate this post, the email notification subscription is also duplicated and I have to manually delete it. I probably need to tell Duplicate Post to not duplicate a custom field. Could you tell me what it may be?

    Thank you!

  5. lopo
    Member
    Plugin Author

    Posted 2 years ago #

    I suppose you're using a plugin for comment subscriptions, can you tell me its name? So I can try to see how it works.

  6. snowmoon
    Member
    Posted 2 years ago #

    Thanks for replying lopo?

    The plugin I'm using is called "Subscribe to Comments Reloaded".

    Thanks!

  7. lopo
    Member
    Plugin Author

    Posted 2 years ago #

    I've checked the plugin, it uses a different custom field for every user, so it can't be excluded from my plugin's options as they are now.

    I will add the option to use wildcards in the next version... Hopefully next week.

  8. snowmoon
    Member
    Posted 2 years ago #

    Thank you!

  9. lopo
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    I'm sorry to say that this feature couldn't make it in version 2.3 (out now).
    I had too little time to find a way to do it, and too many small bugs which needed a quick fix, so I couldn't wait anymore.

    I hope I'll have much more time in the near future. Sorry!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic