WordPress.org

Ready to get started?Download WordPress

Forums

Drafts Scheduler
[resolved] Wow... that sucks (7 posts)

  1. since83
    Blocked
    Posted 3 years ago #

    It deleted all 100 posts i had in draft status.... nice. should be fun explaining that to my users.

    http://wordpress.org/extend/plugins/drafts-scheduler/

  2. Jeff Rose
    Member
    Plugin Author

    Posted 3 years ago #

    Wow, I'm sorry to hear that happened. And quite surprised.

    Drafts Scheduler doesn't/can't delete anything. The word "delete" doesn't appear in the code. It simply updates the date stamp and status of posts.

    Perhaps you could provide some more information so I can look into this.

  3. since83
    Blocked
    Posted 3 years ago #

    I got to looking into it and they arent deleted.. it just posted all 100 post at the same time... which its not suppose to do and when it posted them it didnt post them with a name... all the posts were blank i guess do to the way users use gravity forms to upload content. I had to go through and hand do every post.

  4. Protecting Veil
    Member
    Posted 3 years ago #


  5. Jeff Rose
    Member
    Plugin Author

    Posted 3 years ago #

    Not sure if someone's comment got moderated - got an email, but don't see it here.

    There is an unconfirmed issue with 3.1.1 or a late version of WordPress, however in TRYING to duplicate it it doesn't appear consistently.

    DraftsScheduler does NOT delete posts, ever. However, if the draft is not setup properly by one of the automated tools, they may post immediately or disappear.

  6. Ralph83
    Member
    Posted 3 years ago #

    To fix the mass publising bug, read this bugfix post: http://wordpress.org/support/topic/plugin-drafts-scheduler-bugfixes-mass-publishing-page-scheduling

    @Jeff Rose:

    In case you're wondering what caused this bug:

    If in the database a draft's post_date_gmt date was 0000-00-00 00:00:00 (drafts that have never been published nor scheduled before have this date), the scheduler caused WP (3.1.1.) to publish all drafts which had a post_date_gmt 0000-00-00 00:00:00 date.

    I was able to recreate the bug by setting a draft's post_date_gmt to 0000-00-00 00:00:00 and then run the scheduler. Drafts with a non-zero post_date_gmt date got indeed scheduled, drafts with 0000-00-00 00:00:00 got published.

    I think that when WP 'spots' a draft with a 0000-00-00 00:00:00 post_date_gmt date, it just marks it as 'publish'. Also because your plugin's original code, can't edit the timestamps. So zero remains zero and I think this is the main reason for WP to take over and publish everything.

    Adding 'edit_date' => true to the $update_date array of your plugin, enables your plugin to edit / set post_date as well as post_date_gmt values. WP seems to back off then and it lets your plugin schedule (not publish) every draft it can find.

    I'm glad it works again, because it's a neat plugin! And really needed something to automate scheduling.

  7. Jeff Rose
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks Ralph!

    I appreciate the explanation here, and the thoroughly documented fixes on the other post.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic