WordPress.org

Ready to get started?Download WordPress

Forums

Genesis eNews Extended
[resolved] Plugin doesn't work on my site (10 posts)

  1. fitmole
    Member
    Posted 10 months ago #

    Hi,

    My site is - http://www.fitmole.org/

    I installed the enews extended plugin but it doesn't show up on my site.

    I am using genesis Balance child theme but I did change the homepage from "homepage.php" to "homepage.txt" to get the layout to fit my liking.

    I know this is probably the issue, but is there any way to get the plugin to work even though I changed it to "homepage.txt"?

    Thanks

    http://wordpress.org/plugins/genesis-enews-extended/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    How is it not working? It won't display at all if it isn't configured.

    I believe Balance's styling hides the submit button, so that would require an update to the theme's css. It's not directly related to the plugin.

    Cheers.

  3. fitmole
    Member
    Posted 10 months ago #

    If I put it in the primary sidebar, nothing shows up at all.

    Any idea how to fix it?

  4. wilddigital
    Member
    Posted 8 months ago #

    Hi Brandon,

    I have an issue that is a variation on the above theme! I'm also using Balance and have your lovely mail opt-in on every page of my site aside from the homepage. I'm not too technical and so cannot figure out why this may be. However, I'm aware that the homepage is configured differently to all others in that it is designated as the static landing page.

    My website is http://www.wilddigital.co.uk

    I'd appreciate your feedback.

    All the very best for 2014!

    Best,
    Rachel

    P.S. The 'submit' button you refer to in a previous response within this thread, (default 'GO, I believe), shows up in Balance if my website is anything to go by :0)

  5. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    With Balance, the theme is designed to hide the subscription form on the home page.

    If you check out your theme's style.css at http://www.wilddigital.co.uk/wp-content/themes/balance/style.css

    .home #sidebar .enews,
    .home #sidebar .enews-widget {
    	display: none;
    }

    If that's removed, it'll show on the home page.

    Cheers!

  6. wilddigital
    Member
    Posted 7 months ago #

    Hi Brandon,

    Thanks so much for this!

    I have applied what you have instructed and it took immediate effect on a client's site: http://www.artofoak.co.uk

    However, when I applied it to http://www.wilddigital.co.uk it didn't. (I have a feeling I have got something in my sidebar that may be preventing the opt-in from displaying, and so need to do some serious tweaking on that front it seems...)

    I'm very grateful for your feedback, and the speed with which you responded. All very much appreciated. Thank you.

    The Genesis eNews Extended Plugin really is an incredibly impressive plugin :0)

    All the very best,
    Rachel.

  7. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Thanks :-)

    Check out line 1507 of style.css, looks like that rule is still being applied. Hopefully, that should take care of ya.

    Cheers!

  8. wilddigital
    Member
    Posted 7 months ago #

    Hi Brandon,

    Amazing! Thank you so much :0) I really appreciate your willingness to give your time to respond to this thread.

    I have successfully applied code changes to:

    http://www.wilddigital.co.uk/ (woop! woop!)

    But the same process has not worked for:

    http://www.ecoe.org.uk/

    Any clues as to why this might be would be very much appreciated :0)

    As for my site, (Wild Digital), I really appreciate you not telling me precisely what to do when I discovered the code as described in your last response, (in full below). Whilst I found it perplexing at first it forced me to think for myself, and although I was more than a little scared of applying what I surmised would deliver the fix, the feeling of elation when it worked was wonderful! This has, for sure, increased my confidence where code is concerned, and I am immensely grateful. Thank you!

    I advise everyone who visits this thread with the same issue to give it a go without reading the following. Only resort to what follows if you really come unstuck :0)

    My first issue was that I couldn't see numbered lines of code in the Editor. I didn't really want to use FTP, (as I have managed to avoid facing this challenge thus far), and so I looked for a work around.

    I found a great plugin: WP Editarea
    After installing and activating it all I had to do was go to settings and check the ‘WP Editarea Enable’ box at the beginning of the list
    and then click ‘Update Settings’

    This gave me numbered lines of code to work with.

    Code: 1507 to 1520 revealed two instances of something being 'hidden'

    #footer-widgets {
    background: url(images/gray-texture.jpg);
    clear: both;
    margin: 0 0 20px;
    padding: 25px 0;
    overflow: hidden;
    }

    #footer-widgets .wrap {
    font-size: 13px;
    overflow: hidden;
    margin: 0 auto;
    padding: 0;
    width: 960px;

    Removing ‘overflow: hidden;’ in both instances allows the Genesis eNews Extended Plugin to work on the front page of a Gensis site running the Balance Child Theme.... in most instances!

    Happy days!

  9. wilddigital
    Member
    Posted 7 months ago #

    Update re: http://wilddigital.co.uk

    All is working fine and dandy on all sites I've used the plugin on :0)

    And I have also managed to modify the font and colour in all instances, where required, also.

    Very, very happy with it.
    Many thanks,
    Rachel

  10. heartgeek
    Member
    Posted 5 months ago #

    Rachel,

    How did you modify the font and colour. I managed to get the plugin in the right column by following the directions above. However, I can't change the font.

    Thanks,

    Paul

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.