WordPress.org

Ready to get started?Download WordPress

Forums

WP Welcome Message
Plugin doesn't work in the home page (8 posts)

  1. gknoronha
    Member
    Posted 8 months ago #

    Hello, it's an awsome plugin, but it doesn't work for me ONLY in the home page... it only works if I choose ALL PAGES.
    Can you help me?
    Thanks!!
    Guino

    http://wordpress.org/plugins/wp-welcome-message/

  2. Kabir
    Member
    Plugin Author

    Posted 8 months ago #

    Hello @gknoronha,

    Check the last updated plugin (0.0.2). In this version may not appear that issue, but if it not works then please contact me with your site url.

    Regards
    Kabir

  3. vl4d
    Member
    Posted 7 months ago #

    Version: 0.0.3

    i have same problem (she works only for all pages not only for home page).

  4. mowd
    Member
    Posted 7 months ago #

    I'm having the same problem - I can only get this to work if I allow it to appear on all page. My website is: http://mealsonwheelsde.org/

  5. Kabir
    Member
    Plugin Author

    Posted 7 months ago #

    Please DOWNLOAD a fresh copy and reinstall this plugin, you may copy old files from your localhost or any other host. PLEASE NOTE: install this plugin on a live host/server.

  6. seivadmas
    Member
    Posted 7 months ago #

    I had this problem too.

    Plugin doesn't display on the home page when it is set to Static Page rather than Latest Posts.

    The solution is to change the check in the plugin code. Plugin currently calls is_home() to see if it is on the home page.

    See here for why this probably isn't the desired behaviour: http://codex.wordpress.org/Function_Reference/is_home

    A better option would be to call is_front_page(). See here: http://codex.wordpress.org/Function_Reference/is_front_page

    So, to fix this problem on your website:

    0) This fix will erase your welcome message, so save this to a safe place first.
    1) Go to plugins/installed plugins
    2) Click 'Edit' underneath WP Welcome Message
    3) Make sure you are editing wp-welcome-message/wp-welcome-message.php
    4) In the text box, find is_home and replace with is_front_page
    5) Click Update File
    6) Go back to editing your welcome message, and paste in your previous one.

    That's it! Plugin should display always on the home page now.

  7. Kabir
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks @seivadmas, please check the latest version 0.1.3
    http://wordpress.org/plugins/wp-welcome-message/

    We add another 2 features -
    1. 4 Templates
    2. Check user logged-in or not logged-in, before display welcome message.

  8. schernokov
    Member
    Posted 4 months ago #

    I have the same problem. Downloaded the latest release but when select "Home Page Only" no message is displayed. I use "SPUN" theme. I tried adding the code to wpwm_popupCheckPage function to check for page id. It works, however the pages displays error on the top: "Warning: session_start() [function.session-start]: Cannot send session cache limiter".

    global $post;
    $post->ID;
    if( is_front_page() || is_home() || $postID ==14)

    Could you guide me on how can I resolve it?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.