WordPress.org

Ready to get started?Download WordPress

Forums

WP Maintenance Mode
[resolved] Plugin doesn't work, development site was available to public (5 posts)

  1. deeve007
    Member
    Posted 1 year ago #

    Very unhappy client now, thanks very much.

    http://wordpress.org/extend/plugins/wp-maintenance-mode/

  2. deeve007
    Member
    Posted 1 year ago #

    Worked it out, and it's a major bug!

    If the plugin is active, so your site is blocked, and you then go and change something in the settings, say change the message shown, and then click the "save" button below the settings, this will actually switch of the plugin on the front end, even though it still shows as "True" under "Plugin Activate". You have to then click "Update" button again to reset the plugin as active.

    As I said, major bug when users aren't aware of needing to do this two step process.

  3. Frank
    Member
    Posted 1 year ago #

    Yes, the save was via Ajax and the reload of the WP Backend is important to update all notice on the backend. Thanks for the hint, maybe I find a solution to also update the hint after inactive the status of the maintenance mode.

  4. deeve007
    Member
    Posted 1 year ago #

    The plugin became inactive again for no reason, leaving the site open to the public again.

    I've gone back to using this plugin now: http://wordpress.org/extend/plugins/maintenance-mode/

    Though it hasn't been updated in a while, it works fine... and it just works, unlike your plugin.

  5. Frank
    Member
    Posted 1 year ago #

    Sorry, but I can find a error on the plugin.
    Maybe you can check, after the plugin deactivate it, how is the value of the item in tabel options: wp-maintenance-mode-msqld

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.