WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Plugin doesn't work (9 posts)

  1. MvanT
    Member
    Posted 1 year ago #

    Hi,

    I have a problem. The plugin has worked beautifully, but now it doesn't. I cannot recall any changes which might influence the plugin.

    I think it is theme-related, when I change the theme it does work but again, it has worked...

    My site is http://burgmansrijken.nl/website/

    Thank for any effort!

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. andysb72
    Member
    Posted 1 year ago #

    I'm having the same problem. my images aren't popping up in a fancybox anymore. It should be working on this page (and others) http://roscoandroy.com/thanks-for-compliment/

  3. jerominrebatet
    Member
    Posted 1 year ago #

    Hello,

    MvanT, I can't see any "fancybox" class for your images or div, it could be the issue ?
    And andysb72, it seems to work great so i think you figured out.

  4. MvanT
    Member
    Posted 1 year ago #

    Thanks, Jerominrebatet, for your advice. It sure looks like that where the class should be fancybox, the class="attachment-thumbnail". I didn't change anything to the plugin pages... Any idea how this could be affected?

  5. jerominrebatet
    Member
    Posted 1 year ago #

    There's the fancybox class now on the div tag, but you should try to remove the "attachment-thumbnail" class on img tag.
    I don't have any other idea for now :/

  6. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi MvanT, your site is loading jQuery through http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=3.5 and I suppose the issue occurred the moment Google put jQuery 1.9 up there... You need to find out why (your theme? another plugin?) your site is using this version instead of version 1.8 that is included in WordPress.

  7. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Andysb72, I notice you are using WP Slimstat. I remember encountering an issue with that... See http://wordpress.org/extend/plugins/easy-fancybox/other_notes/ but no idea if that is the case since you switched plugins so I cannot debug anymore ;)

  8. MvanT
    Member
    Posted 1 year ago #

    Thanks, RavanH (volgens mij kan het ook in het Nederlands :-))

    It works! I replaced "http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=3.5" in my theme with "http://ajax.googleapis.com/ajax/libs/jquery/1.8.0/jquery.min.js". Problem solved!

  9. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    @MvanT Geweldig :)

    By the way, it stikes me as weird (or at least a possible source for future issues) that your theme has the jQuery call hardcoded. Or is it inside functions.php that this is defined with wp_enqueue_script? If so, I suppose it's all good ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic