WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
[resolved] plugin doesn't play well with ssl (10 posts)

  1. Oudin
    Member
    Posted 1 year ago #

    I have ssl enabled on my site it appears that this plugin is not loading resources via https:// which is causing the browser to display "connection is partially encrypted"

    http://wordpress.org/extend/plugins/store-locator-le/

  2. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    I have not tried this on a fully secured SSL site, however most of the plugin components use the URL returned by the WordPress site URL function call. If you are using custom markers you may want to make sure they have either a relative URL or are using a fully qualified HTTPS URL.

  3. Oudin
    Member
    Posted 1 year ago #

    Thanks for the reply,

    I'm not using any custom markers.

    I'm using the plugin as is, all other resources on the site URL's have https:// applied to them whoever resources from this plugin does not.

    If the plugin was loading it's resources only the page shortcode was used that would have been great

  4. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Turn off "force load javascript" in the map settings area and it will only load on the page where it appears.

    Unfortunately 20%+ of the themes out there are not following WordPress 3.3 best practices and do not support proper "late loading" (footer processing) of scripts. Thus I had to turn ON force load javascript so the plugin works on a higher percentage of sites.

  5. Oudin
    Member
    Posted 1 year ago #

    disabled.

    I do not know what it is but when I this able this plugin I do not get the "connection is partially encrypted" warning.

    but as soon as I enable the plugin it's back

  6. Oudin
    Member
    Posted 1 year ago #

    The line below is still being loaded on each page even with "force load javascript" disabled

    <script type='text/javascript' src='http://maps.google.com/maps/api/js?sensor=false&v=3.9&key=AIzaSyD5pa5A34ddpFkYibBZHojs0PfeK6ekCyk&ver=3.4.2'></script>

    This same file can be access via https://

  7. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    I've created the patch which should resolve this when 3.7.6 is released next week. As long as your WordPress install responds to the built-in is_ssl() function provided by WordPress it should resolve the issue.

    Thanks for reporting the problem.

  8. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    3.7.7 is out and should help fix this. Let me know if the new release does the trick.

  9. Oudin
    Member
    Posted 1 year ago #

    The update works great, thanks for the quick work.

  10. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Glad it worked. Thanks for the update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags