WordPress.org

Ready to get started?Download WordPress

Forums

WP-PostViews
[resolved] Plugin doesn't count (26 posts)

  1. cedriclocqueneux
    Member
    Posted 11 months ago #

    Hi,

    I have a new wordpress installation 3.6 and your plugin in last version.
    But the plugin doesn't count any visit. Configuration is on "evry body", but counter stay at 0. I don't understand, is there other thing to do ?

    http://wordpress.org/plugins/wp-postviews/

  2. kinddylee
    Member
    Posted 11 months ago #

    HI,
    I solved this problem several munites ago.
    You should add "<?php wp_head(); ?>" before "</head>" in your "header.php" file.

  3. mastercho
    Member
    Posted 10 months ago #

    i dont have </head> in my header.php faile how to fix it ? can owner update with fix ?

  4. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    @mastercho: that is your theme issue, please contact your theme author.

  5. mastercho
    Member
    Posted 10 months ago #

    but in old version was working perfect

  6. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    If you upgraded WP-Postviews whether or not you are using WP 3.6 or earlier, without the code in your theme it will not work.

  7. manuman
    Member
    Posted 10 months ago #

    I have "<?php wp_head(); ?>" and "<?php wp_footer(); ?>" in the corresponding files and it still not count.

  8. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    @manuman: make sure you are not using any caching plugin. Caching plugin will still count the votes but the display will be the older views because it is cache.

  9. manuman
    Member
    Posted 10 months ago #

    So what do I have to do? Remove my cache plugin?
    :/

  10. batori
    Member
    Posted 10 months ago #

    Hi,

    I have a similiar problem.

    - Im having : "<?php wp_head(); ?>" in header.php before "</head>"

    - Im having this as footer :

    "<?php wp_footer(); ?>
    <div id="footer">
    </div>"

    - I did add stuff to index.php, single.php, ecc... but what it shows is always 0 views. W3 cache plugin disabled/enabled still the same thing.

    Any ideas?

    Cheers!

  11. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    @manuman, @batori: to check whether it actually counts, wp-postviews stores the views count in the custom meta field. You can find this field value when you edit the post.

  12. manuman
    Member
    Posted 10 months ago #

    It's not counting http://i.imgur.com/vJLHJEq.png

  13. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    manuman: what is ur site URL? Are you still using any caching plugin?

  14. manuman
    Member
    Posted 10 months ago #

    You can see it in the screenshot I sent you

  15. batori
    Member
    Posted 10 months ago #

    It counts in edit page! But now showing otherwise...

  16. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    @batori: that means there is nothing wrong with the plugin and your caching plugin is caching the output of the page.

    @manuman: can you type for me?

  17. batori
    Member
    Posted 10 months ago #

    Im sorry i misguided word count for view count ... i dont even have view count in the edit page :(

    is there a way to check in the db for view count?

  18. manuman
    Member
    Posted 10 months ago #

    Sorry Lester,

    I may have been rude before. Here you have:
    http://www.esp iaenelc ongreso.com
    All together (I put blank spaces for security reasons)

    I want to maintain my caching plugin. Is it incompatible with yours?

  19. Lester Chan
    Member
    Plugin Author

    Posted 10 months ago #

    @manuman no worries man, I don't think that is rude, sometimes different people from different countries have different culture and they might express themselves differently =)

    I think you might not have <?php wp_footer(); ?> in your theme footer.php. If you have it, you cache might be an outdated one. Because when I view the HTML source of your page, there are some JS variables that are missing. Force a refresh or delete your cache, so that it will generate?

    @ batori: site url please?

  20. batori
    Member
    Posted 9 months ago #

    Here it is Lester : 2popcorns . com

    in the posts page in admin panel i have views column which says 0 and 1 nothing else ... strange

  21. Lester Chan
    Member
    Plugin Author

    Posted 9 months ago #

    @ batori : it is counting for me http://2popcorns.com/?p=41 now have 3 views

  22. batori
    Member
    Posted 9 months ago #

    It's really strange.It didnt count before and now it counts but seems not counting in real time?? i clicked many times on the post in few days and all i see is 1 vews and 1 post has 3 views??

  23. Lester Chan
    Member
    Plugin Author

    Posted 9 months ago #

    i click twice, it was once when i saw it.

  24. batori
    Member
    Posted 9 months ago #

    ima clicking as we speak and count is not changing...why is that?

    there must be saome sort of solution?

    Cheers!

  25. Lester Chan
    Member
    Plugin Author

    Posted 9 months ago #

    In the WP-Admin -> Settings -> PostViews, did u set to count Guest only?

  26. batori
    Member
    Posted 9 months ago #

    Oh my friend, thank you very much, i did not even know about that option :( im so sorry. Now it works! I changed that Guest only option!

    THANK YOU VERY MUCH FOR YOUR TIME AND SUPPORT! I REALLY APPRECIATE IT!

    Cheers man!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.