WordPress.org

Ready to get started?Download WordPress

Forums

Lazy Load for Videos
[resolved] Plugin does not work - Issue with 3.8? (5 posts)

  1. findlay70
    Member
    Posted 6 months ago #

    Hi Kevin -
    I deactivated all plugins. Then created a new post with a youtube iframe in the post. The video shows the JS and not an image.
    I cleared all cache and still didnt work. I am using 3.8 and have the basic theme installed. I am assuming this works in an iframe?
    my URL is funnyleak dot com. (please dont link anything back to my site).
    Thanks for your support
    Andy

    http://wordpress.org/plugins/lazy-load-for-videos/

  2. findlay70
    Member
    Posted 6 months ago #

    I think I know what is wrong with this. I have been adding the youtube video in the post in an iFrame. So the plugin does work with a copied URL from youtube, but I still have a question:

    Just adding the YT link works, but if you look at the video, the edges are trimmed - the preview image is not displaying the full size. Is there any way to adjust the preview image?

    Any way to fix this?

    Thanks and appreciate your support
    Andy

  3. kevinweber
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Andy,

    you can add the following CSS code to your theme's CSS file in order to adjust the preview image:
    a.lazy-load-youtube, .lazy-load-vimeo { background-size: cover !important; }

    Does this solve your problem?

    Best regards,

    Kevin

  4. findlay70
    Member
    Posted 6 months ago #

    Yes, this works perfectly, thanks Kevin!

    Just another question, please - where does the plugin get the thumbnail from and is there a way to:
    1. Change the thumbnail
    2. Improve the quality of the thumbnail?

    Also, I am used to having a number of parameters added within an ifrane, but having a URL seems it cannot have a number of parameters. Is there a way to add these in? https://developers.google.com/youtube/player_parameters

    Danke für Ihre Hilfe
    Andy

  5. kevinweber
    Member
    Plugin Author

    Posted 6 months ago #

    The plugin gets the thumbnail from Youtube directly. So you can't change it.

    In some cases it would be possible to have a thumbnail with better quality – but not in all cases. So I leave the plugin as it is (no better quality for thumbnails). Besides, that's better for your page load time.

    To your last question, maybe this thread can help you: http://wordpress.org/support/topic/plugin-does-not-work-when-using-the-youtube-embed-code-from-youtube?replies=4

    Regards,

    Kevin

Reply

You must log in to post.

About this Plugin

About this Topic