WordPress.org

Ready to get started?Download WordPress

Forums

DMSGuestbook
[resolved] Best way to disable form? (9 posts)

  1. Vince LaMonica
    Member
    Posted 1 year ago #

    I use this great plugin with an "in memoriam" website that I made a few years ago for my grandmother. The plugin served as a place that people could "sign a guestbook" for those unable to attend her funeral. I keep the website up to date and maintained with the latest versions of WP, the plugins, themes, etc.

    Lately I've been swamped with spam comments into the guestbook. They are all successfully flagged as spam, but I get e.mailed whenever one comes in and I have to clear them out a few times a day. I've switched from using a math quiz to using reCaptia, but the spam has only gotten worse. I'd like to continue to display the guestbook entries, but I'd like to remove the form to submit the entries, as there has not been a valid guestbook entry in over 2 years. Is this something one can do via the default.tpl template in the template/form directory? Any information you can provide would be quite helpful. Thanks!

    Kind regards,

    /vjl/

    http://wordpress.org/extend/plugins/dmsguestbook/

  2. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    If you no longer need the ability to post guest book messages, the best way might be to remove the plugin after copying the text of the existing entries into a page.

  3. DanielSchurter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vince

    Create a new text file, insert following text on it
    <?php ?>
    and save the file as empty.tpl

    Move the file to "plugins/dmsguestbook/template/form" and go to DMSGuestbook admin panel "DMSGuestbook -> Guestbook settings -> Extended -> Form template", switch to empty.tpl and save it.

    Now, there isn't any longer a form on your website but all entries would display.

    Greetings,
    Dani

  4. Vince LaMonica
    Member
    Posted 1 year ago #

    Hi Dani,

    Thank you *so* much for that info - it worked perfectly and now the guestbook displays entries that people have made in the past, and no way to make new ones. This is perfect! Thank you again - much appreciated!

    Kind regards,

    /vjl/

  5. quepaso
    Member
    Posted 1 year ago #

    Thanks for the fix, Dani! It removed the form, but now i'm having this piece of css showing up:
    http://oi47.tinypic.com/v7gjcx.jpg
    Any ideas on how to fix this?
    Thanks in advance!

  6. DanielSchurter
    Member
    Plugin Author

    Posted 1 year ago #

    Did you edit this with MS Word? I suggest you using an editor like Notepad++

    Greetings,
    Dani

  7. quepaso
    Member
    Posted 1 year ago #

    I used the default Mac text editor. Doest it matter if its Notepad ++ since there's only one line of code?
    Thanks!

  8. DanielSchurter
    Member
    Plugin Author

    Posted 1 year ago #

    This line of code isn't css, I suggest start with a new downloaded default.tpl file. Be sure the editor have to save text without any formating content.

    Dani

  9. quepaso
    Member
    Posted 1 year ago #

    Thanks a bunch, Dani, that fixed it! I edited the copy of default.tpl file, and it worked (I used TextWrangler)

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags