WordPress.org

Ready to get started?Download WordPress

Forums

Disqus Comment System
Disqus Not Respecting Per-Post Allow Comments Option (7 posts)

  1. helton
    Member
    Posted 2 years ago #

    Suddenly Disqus has started displaying comments form and thus accepting comments on posts where Discussion has been turned off via WP Editor (ie there is no checkmark against Allow comments on those posts.)

    It used to respect that setting. Is this a bug? If yes, is there a workaround?

    Thanks in advance.

    http://wordpress.org/extend/plugins/disqus-comment-system/

  2. helton
    Member
    Posted 2 years ago #

    Could anyone confirm if this is indeed an issue before I either disable Disqus or investigate further with my installation, please?

    All my old posts with comments turned off are now receiving trolling/spamming comments again (which I really do not want!) :( and I don't want Disqus uninstalled!

    Thank you.

  3. Talton
    Member
    Posted 2 years ago #

    This would most likely have something to do with your theme. To test, try changing your theme to see if this still occurs.

    Disqus also allows you to close your comments outside of WordPress using the inline settings shown here: http://dl.dropbox.com/u/31679327/Screenshots/2ha.png

    Additional information on closing your commenting threads through Disqus can be found here: http://docs.disqus.com/help/18/

    If you have any other questions, feel free to send us a note via our support page: http://disqus.com/support

  4. helton
    Member
    Posted 2 years ago #

    Thank you Talton. I ended up closing the thread via Disqus outside of WP Editor.

    I will dig deeper into the theme later, the theme hasn't changed and this bug only just started affecting it after WP upgrading to 3.3.1.

    Thank you.

  5. Talton
    Member
    Posted 2 years ago #

    Something else that might be happening is that you may have approved comments within WordPress for that post or page. If so, WordPress will continue to keep that post open. If you'd like to removed comments from that page entirely, you'll need to unapprove all comments for that page within WordPress.

    You can see whether or not this Page has approved comments from the Pages > All Pages tab shown here: http://dl.dropbox.com/u/31679327/Screenshots/2hu.png

    Click the comment bubble and it'll take you to a list of all the comments on that specific page where you can unapproved them in bulk.

  6. helton
    Member
    Posted 2 years ago #

    Thank you Talton.

    The posts in question all have existing published comments, but the commenting was turned off so that no new comments are received.

    I actually assumed that's the purpose of the per-post Allow Comments setting (ie, turn off/on receiving new comments, but keep displaying the old ones.) Disqus was also respecting this until something happened either with my theme or WP upgrade to 3.3.1.

    Thanks.

  7. tsvenson
    Member
    Posted 1 year ago #

    I stumbled on this issue for another Disqus problem I have, but I too have noticed problems with this.

    It seems that the the Disqus plugin only looks at the global setting. If you have comments turned off as default, it is not possible to turn them on on individual posts.

    Even if you first turn them on for the post, then also globally Disqus will show up for already existing posts. After turning it on globally Disqus simply will only show up for new posts.

    Pages does not have comments turned on by default, still Disqus shows up and there is nothing I can do in the UI to fix this.

    The only solution in that case I have found is to hack the code as described on this page http://zackeryfretty.com/removing-disqus-comments-from-wordpress-pages/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic