WordPress.org

Ready to get started?Download WordPress

Forums

Disable Comments
[resolved] Globally disabling Media fails (5 posts)

  1. Randy Sandberg
    Member
    Posted 1 year ago #

    Hello, we're using your latest version of Disable Comments (v0.6) and have checked/saved ALL boxes on its Settings page--including Media and use permanent mode--and still have a comment box on our Media pages (e.g., http://www.beautomated.com/?attachment_id=2927).

    http://wordpress.org/extend/plugins/disable-comments/

  2. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Randy,

    This appears to be a problem with your theme - because on the link you provided, it says "Comments Off" below the title, and then still displays a comment form. Hence the theme is printing a comment form even when it knows comments are closed.

    If you can email me a copy of your theme's image template (image.php and/or attachment.php from your theme folder), we can verify this. My email address is here.

  3. Tevya
    Member
    Posted 1 year ago #

    I'm having a similar problem with media attachements: http://fiddlerstudios.com/how-to/websites-that-speak-google/attachment/seo-google/ I've disabled comments on media, and even turned on the "permanent" mode, but still no luck. It's a WooThemes theme, so I'd expect it to be well written and to behave nicely, but it doesn't seem to be.

    Any ideas? Or should I email my image.php or attachment.php file as well?

  4. solarissmoke
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tevya - on the link you gave above, it says "Comments are Closed", so it seems to be working?

    In any case, I notice you have WP Super Cache installed. You will need to reset/invalidate your cache before these changes will show up. I suspect this is why they didn't show up at first (or are not showing up for you).

    If you still have a problem, let me know.

  5. Tevya
    Member
    Posted 1 year ago #

    Huh! Well yeah, it looks like it's working now. I actually deleted the cache several times, as well as looking at it while logged-in (WP SuperCache is set to be disabled for logged-in users) and the comments field was still there. However, it appears that somehow it was showing me the cached version or something.

    Working now! Thanks for following up even though it appears it was already working, but I couldn't see that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.