WordPress.org

Ready to get started?Download WordPress

Forums

devMX TeamSpeak3 Webviewer
[resolved] The widget/code doesn`t show (8 posts)

  1. buzzito
    Member
    Posted 1 year ago #

    Hi, beforehand thanks for your work.

    I installes the plugin, correctly.
    I created a config called "ts3"
    I loaded the widget in the sidebar, and tried many weight values in px and %.

    But when I join my site, nothing appears... and every other widget that's after the ts3 doesn't load...

    I tried creating a new page, and I pasted the code [tswv id="ts3_1"] or [tswebviewer id="ts3_1"], and it doesn't do nothing.

    I hope u know what's happening, or what im doing wrong. :S

    http://wordpress.org/extend/plugins/devmx-teamspeak3-webviewer/

  2. ZombieTwiglet
    Member
    Posted 1 year ago #

    I'm getting exactly the same issue.

    WordPress 3.4.2

  3. maxe___
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,
    we have this issue quite often, but we didn't find a solution yet because we cannot reproduce it.

    Can you please post me your system configuration? PHP Version? Webserver? Selfhosted or rented?

  4. ZombieTwiglet
    Member
    Posted 1 year ago #

    Debian 6
    PHP 5.3.17-1~dotdeb.0 with Suhosin-Patch
    Lighttpd 1.4.28-2
    TS3 x64 3.0.6.1
    WordPress 3.4.2
    Webviewer 1.2.1

    Self hosted, can connect to TS3 via telnet (from localhost and externally) using the same details.

    Just enabled debugging and error reporting and this is the dump:

    Warning: fsockopen(): unable to connect to tcp://localhost:10011 (Connection refused) in /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/Transmission/TCP.php on line 106 Fatal error: Uncaught exception 'RuntimeException' with message 'Cannot connect: Establishing failed with code 111and message Connection refused' in /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/Teamspeak3/Query/QueryTransport.php:114 Stack trace: #0 /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/TSWebViewer/TSWebViewer.php(98): devmx\Teamspeak3\Query\QueryTransport->connect() #1 /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/TSWebViewer/TSWebViewer.php(185): devmx\TSWebViewer\TSWebViewer->establishConnection() #2 /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/Wordpress/TSViewer/TSViewer.php(247): devmx\TSWebViewer\TSWebViewer->renderServer(Object(devmx\TSWebViewer\RenderOptions)) #3 /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/Wordpress/TSViewer/TSViewer.php(193): devmx\Wordpress\TSViewe in /var/www/blah/public_html/wp-content/plugins/devmx-teamspeak3-webviewer/lib/devmx/Teamspeak3/Query/QueryTransport.php on line 114

    From what I can see 111 is connection refused, however it works fine over telnet as I mentioned.

    Config in use is:

    ID 	Configname 	Serveradress 	Serverport 	Queryport 	Username 	Custom icons download 	Country icons 	Caching enabled 	Caching time
    	1 	CarmaCraft 	localhost 	9987 	10011 	serveradmin 	Yes 	No 	Yes 	180

    Hope that helps!

  5. maxe___
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for that reply! :)
    The debugging info and error gave us the hint.

    The problem is the error handling of the plugins, that's why there is a white page or the whole page crashes if an error occures.

    We could also reproduce the issue now. But unfortunately it will take a while to fix it.

    This is very strange that the server refuses the connection from php but not from telnet. Did you also try to enter the external adress of the server as Serveradress?

    Regards!

  6. ZombieTwiglet
    Member
    Posted 1 year ago #

    I hadn't thought of that, putting the external address works. How very strange.

  7. maxe___
    Member
    Plugin Author

    Posted 1 year ago #

    Hm thats quite strange.
    We releasead a new version today which should fix the page crash/ white page problem and instead shows an error message.

  8. crota
    Member
    Posted 1 year ago #

    I have a similar issue.

    My best guess is the setting in TS called:
    Server Groups>Guest>Virtual Server>ServerQuery: Select Virtual Server
    Is not activitated. I can't add this permission because I am not the TS owner. Is this option required?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.