WordPress.org

Ready to get started?Download WordPress

Forums

Device Theme Switcher
[resolved] Support for Chrome on Android (7 posts)

  1. devjess
    Member
    Posted 1 year ago #

    Hi there,

    I realize that you don't take care of the MobileESP project but I was looking to see what the status is on Chrome for Android devices (Galaxy SII). Seems that it's passing through as a desktop browser :)

    I took a look at the main project site but I can't seem to easily find a supported device list to cross reference and since you most likely have an open line of communication to them you might be the best one to check on this?

    Appreciate it!
    Jess

    http://wordpress.org/extend/plugins/device-theme-switcher/

  2. James Mehorter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jess,

    I'm looking into it and will post back what I find. Thanks for letting me know!

    James

  3. James Mehorter
    Member
    Plugin Author

    Posted 1 year ago #

    Jess can you navigate to http://whatsmyuseragent.com/ on your phone and post back the results here?

  4. James Mehorter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jess, please let me know what the useragent is from visiting that website above on your device using Chrome.

    I've spoken with the dev at MobileESP and run some tests, and the Chrome for Android is detected correctly from our tests. Are you sure you set the correct theme in Appearance > Device Themes?

  5. gergokuzd
    Member
    Posted 1 year ago #

    Hi James,

    I have the same problem as Jess above but on my iPad. Chrome on my iPad redirects to the full desktop theme but safari on my iPad redirects correctly to the tablet theme.

    FYI, chrome on my android phone (samsung galaxy nexus) redirects correctly to the mobile theme.

    The user agent for Chrome on the iPad that doesn't work is below:
    Mozilla/5.0 (iPad; CPU OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A403 Safari/8536.25

    Any ideas?

  6. James Mehorter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi gergokuzd,

    I've just tested this on my iPad, using Chrome, and the correct theme is served up for me. Can you verify that you've set your themes correctly in 'Appearance > Device Themes' ?

  7. gergokuzd
    Member
    Posted 1 year ago #

    Hi James, this has magically started working now for me too as well!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.