WordPress.org

Ready to get started?Download WordPress

Forums

Device Theme Switcher
[resolved] Older Blackberry devices not being detected (5 posts)

  1. Aaron
    Member
    Posted 2 years ago #

    Repost to a new topic:

    my client who I created a web site for using this plugin is complaining that some of the older OS7 Blackberries are not getting picked up and shown the mobile site...

    Have you experienced this in your testing or has anyone else encountered this issue?

    Client is saying:
    "I get the full site on the older OS7 Blackberries (all except the Bold 9900 and Bold 9930) "
    "the Curve still loads the full site. "

    Here is a User-Agent info log of one of the devices:

    User-Agent.Info

    User-Agent:Mozilla/5.0 (BlackBerry; U; BlackBerry 9350; en-US) AppleWebKit/534.11+ (KHTML, like Gecko) Version/7.0.0.261 Mobile Safari/534.11+
    Accept:text/html,application/xhtml+xml,application/xml,application/x-javascript,*/*;q=0.5
    Accept-Charset:
    Accept-Encoding:gzip,deflate
    Accept-Language:en-US,en;q=0.5
    Connection:close
    Protocol:HTTP/1.1
    Common Gateway Interface:CGI/1.1

    Thanks for the help.

    http://wordpress.org/extend/plugins/device-theme-switcher/

  2. James Mehorter
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Aaron, thanks for starting a thread.

    I'm going to run some tests and let the guys at MobileESP know about the missing support. I'll report back when I can release an update for Device Theme Switcher with the added support. It may take some time, so please ask your client to be patient.

    Thanks Aaron,

    James

  3. Aaron
    Member
    Posted 2 years ago #

    No problem. They completely understand. I appreciate your help.

  4. James Mehorter
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Aaron, just wanted to give you an update that we'll be releasing a new version of the plugin which adds support for some of the devices you mentioned. You can expect an update in the coming days. Thanks.

  5. James Mehorter
    Member
    Plugin Author

    Posted 2 years ago #

    Hi again Aaron,

    I've released version 1.6 of Device Theme Switcher which includes the latest MobileESP library which includes more support for BlackBerry's. Let me know if this does the trick for you or not.

    Thanks,

    James

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.