WordPress.org

Ready to get started?Download WordPress

Forums

Developer's Custom Fields
[resolved] Old jquery conflicts with other plug-ins (3 posts)

  1. llucax
    Member
    Posted 2 years ago #

    I'm using Developer's Custom Fields 0.6.1 but it breaks other plugins (specifically Advanced Access Manager) because both uses conflicting jquery versions.

    Would it be possible to use the built-in jquery or a more modern version to avoid this conflict?

    Thanks for the great plug-in.

    http://wordpress.org/extend/plugins/developers-custom-fields/

  2. Steve Taylor
    Member
    Plugin Author

    Posted 2 years ago #

    Hi llucax, thanks for the feedback! Version 0.7 (due soon) includes some jQuery updates. Hopefully this will address your problems.

    To be clear, the plugin relies on the default WP jQuery library (i.e. the one in the core, unless you use something like Use Google Libraries, which will override it with the one from Google's API library). It also uses the default jQuery UI core. It uses its own copy of jQuery UI Datepicker, which was version 1.7.3 until 0.7, which will use the latest (1.8.16).

    There are issues with the gmap field type's "Find address" tool, because we use autocomplete, which was dropped from WP core in 3.0 in favour of suggest. We didn't notice because we run Use Google Libraries by default, and the jQuery UI from Google seems to include autocomplete! Until we manage to convert to suggest, we advise using the Use Google Libraries plugin.

  3. Steve Taylor
    Member
    Plugin Author

    Posted 2 years ago #

    Update: it looks like WordPress 3.3 will be shipping with jQuery UI 1.8.16, including "the full UI including widgets and effects". So I should be able to use Datepicker from the core, as well as Autocomplete. Hurrah!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic