WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Developer Formatter] Line breaks removed on edit (2 posts)

  1. thedude458
    Member
    Posted 5 years ago #

    Using the visual editor, everything works fine when I initially create a post. However, if I edit a post I noticed that line breaks that were put in after the end of the code snippet are removed.

    For instance, I may enter a code snippet in to the visual editor, followed by some text, such as....

    class Foo {
    public:
      // ... more code
    }; <--- code snippet ends here
    
    This would be an explanation of the code.

    In the original post, there would be two line breaks after the code snuppet ends. However, if I leave the post entry screen, and come back to edit it later, the extra line break is deleted, and it ends up looking like...

    class Foo {
    public:
      // ... more code
    }; <--- code snippet ends here
    This would be an explanation of the code.

    I really like the plugin, but it makes it difficult to edit posts, because I am constantly having to re-add extra line breaks every time I wish to make a change.

    http://wordpress.org/extend/plugins/devformatter/

  2. GSaraiva
    Member
    Posted 4 years ago #

    Man, you found a bug on wordpress editor :).

    Disable the plugin and try again. You'll see the double line problem again.

    Report this at: http://wordpress.org/support/forum/3
    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic