WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Developer Formatter] After install many php error in setting page (13 posts)

  1. alantang888
    Member
    Posted 4 years ago #

    Hello,

    After I install this plug-in in setting/DevFormatter 2009.0.1.29 got many php error, how to fix it??

    DevFormatter display & WordPress display:
    Warning: Invalid argument supplied for foreach() in /opt/httpd/alan/blog/wp-content/plugins/devformatter/devcommon.php on line 160

    Supported Languages:
    Warning: Invalid argument supplied for foreach() in /opt/httpd/alan/blog/wp-content/plugins/devformatter/devinterface.php on line 182

  2. GSaraiva
    Member
    Posted 4 years ago #

    Thats something I'll change later, but you can solve it accessing the DevFormatter configuration page and clicking on the "Update List" button at Supported Languages display.

    thanks

  3. alantang888
    Member
    Posted 4 years ago #

    Thx for reply, but I click the "Update List" button, the big textbox sill show

    "Warning: Invalid argument supplied for foreach() in /opt/httpd/alan/blog/wp-content/plugins/devformatter/devinterface.php on line 182"

    Thx ^^

  4. GSaraiva
    Member
    Posted 4 years ago #

    At some lines above you can see a phrase:
    "You have X supported languages."
    X as a number.

    The actual number is ~139, otherwise you have a problem on the instalation. Check the GeSHi path on the ftp and see there all control files for each language.

    If everything is fine, and the problem persists, try to remove the plugin and upload it to the ftp again with all files.

    ^^

  5. alantang888
    Member
    Posted 4 years ago #

    Hello,

    i checked the X is show 0, and "/opt/httpd/alan/blog/wp-content/plugins/devformatter/geshi/geshi" got 139 php files, i tried remove all file then reinstall again, but still got same problem.....

  6. GSaraiva
    Member
    Posted 4 years ago #

    Try yo change the directory of geshi languages to "./geshi/geshi" on the configuration page.
    If that don't resolve, you'll need to check your permissions, and what version of php you are using. DevFormatter is compatible with php 5+.

  7. alantang888
    Member
    Posted 4 years ago #

    I did try to change the directory of geshi languages to ./geshi/geshi, but after i click save button, that settin back to /opt/httpd/alan/blog/wp-content/plugins/devformatter/geshi/geshi.

    I set the /opt/httpd/alan/blog/wp-content/plugins/devformatte apache permission to rwx, the php version is 5.2.5

    Thanks ^_^

  8. GSaraiva
    Member
    Posted 4 years ago #

    Really strange this problem.
    Another cause can be the mySQL table, check if there was {wp_}"devfmt_config" and {wp_}"devfmt_supplang".

  9. ecartz
    Member
    Posted 4 years ago #

    There is a bug in devinstall.php. There is an extraneous comma at the end of the list of columns for {wp_}devfmt_config:

    showtools tinyint(1) DEFAULT '1',

    This causes the install to fail and never populate the programming languages. I ran the SQL manually (getting an error on the syntax) and then revised the SQL so it would pass. Then I uninstalled and installed the plugin and things seem to be working.

    Presumably the code should be

    $sqlDevFmtConfig = "CREATE TABLE {$table_prefix}devfmt_config (
          geshilangpath varchar(255) CHARACTER SET utf8 NOT NULL,
          geshiuselink tinyint(1) NOT NULL DEFAULT '0',
          displaylinenumbers tinyint(1) NOT NULL DEFAULT '1',
          usedevformat tinyint(1) NOT NULL DEFAULT '1',
          devfmtcss text CHARACTER SET utf8,
          linkjquery tinyint(1) DEFAULT '1',
          highlighttags tinyint(1) DEFAULT '0',
          copyclipboartext varchar(100) CHARACTER SET utf8 DEFAULT NULL,
          parsepre tinyint(1) DEFAULT '1',
          hookrss2 tinyint(1) DEFAULT '1',
          devversion varchar(30) CHARACTER SET utf8,
          showtools tinyint(1) DEFAULT '1'
        );";

    Not sure whether this is a problem in all versions of MySQL -- it's actually a Perl Best Practice (according to Damian Conway) to make lists this way, but it doesn't seem to work in my MySQL.

  10. GSaraiva
    Member
    Posted 4 years ago #

    Yeah, I've checked the compatibility with some mysql versions, and sometimes this can bug the installation.

    I've implemented a new system for languages and configurations manipulation.

    Version 2009.0.1.30 uses another configuration system, don't create tables anymore. Retrocompatibility has been implemented.

  11. alantang888
    Member
    Posted 4 years ago #

    I upgraded to Version 2009.0.1.30 the problem fixed, many thanks ^_^

    I love this program !!!

  12. alantang888
    Member
    Posted 4 years ago #

    another question, can it set to word warp??

  13. GSaraiva
    Member
    Posted 4 years ago #

    You're enable to set the width and height of the code area, like this:
    <code lang="php" style="width: 100px; height: 200px">

    And sorry, word-wrap will be not avaliable so soon, the devformatter's target is to keep the code like a code-editor.

Topic Closed

This topic has been closed to new replies.

About this Topic