WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Plugin deactivated for security reasons (9 posts)

  1. Andreas Beer
    Member
    Posted 1 year ago #

    Latest version seems to have some hickups.

    This is what I get on activation:
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 210
    Warning: Invalid argument supplied for foreach() in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 212
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 210
    Warning: Invalid argument supplied for foreach() in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 212
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 210
    Warning: Invalid argument supplied for foreach() in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 212
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 219
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 219
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 219
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 226
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 226
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 226
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233
    Warning: exec() has been disabled for security reasons in /www/htdocs/boing/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 233

    This is my system:
    Operating System : Linux
    Server : Apache
    Memory usage : 55.92 MByte
    MYSQL Version : 5.5.28-nmm3-log
    SQL Mode : Not set
    PHP Version : 5.4.9-nmm1
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 256M
    PHP Max Upload Size : 200M
    PHP Max Post Size : 200M
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    That message means someone turned off the PHP exec() function on your server. This plugin requires exec() and there is no way around it. The timing with the plugin upgrade is pure coincidence.

  3. benfrain
    Member
    Posted 1 year ago #

    Interesting, I have exactly the same problem. I'm on a VPS so I'm pretty sure the server hasn't had anything changed. Was fine before the upgrade, I now get the message:

    EWWW Image Optimizer requires exec(). Your system administrator has disabled this function.

  4. Andreas Beer
    Member
    Posted 1 year ago #

    The operator of my managed sever told me, that installing exec() would pose a severe security risk. So I'll just have to do without this plugin.

  5. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    benfrain, the best you can do is ask your server operator to turn on exec(). If they won't, you can't use the plugin, just like Andreas said.

    exec() can be a security risk, if not handled properly, and I suppose a lot of people aren't very careful with it. I am, but for some server operators, it just isn't worth the risk.

  6. benfrain
    Member
    Posted 1 year ago #

    Can you confirm - this was working fine in previous versions - didn't get any message about exec() - was the requirement for exec a recent addition?

  7. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    The exec() function has been required since version 1.0 (the very first release). It is what allows us to use command line optimizers with PHP.

    So your server operator probably went, "oh crap, someone is using exec(). I heard that was a security risk, better disable it..."

    You can even try an older version to confirm it:
    http://wordpress.org/extend/plugins/ewww-image-optimizer/developers/

  8. ddibbz
    Member
    Posted 5 months ago #

    I am having the same issue, (EWWW Image Optimizer requires exec(). Your system administrator has disabled this function.) I have full control over my phpMyAdmin. What do i need to do to activate your plugin? Does it need permission settings? what file exactly is it trying to access? Can I upload it into my php? I'm getting frustrated. HELP ME! Please?

  9. nosilver4u
    Member
    Plugin Author

    Posted 5 months ago #

    ddibbz, please start a new thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.