WordPress.org

Ready to get started?Download WordPress

Forums

DB Cache Reloaded
Plugin Broken with WP 3.1 (34 posts)

  1. jfrovich
    Member
    Posted 3 years ago #

    This the error i get

    DB Cache Reloaded Error: wpdb class is redefined, plugin cannot work!
    Previous definition is at /home/xxx/public_html/xxx.com/wp-includes/wp-db.php:52.

  2. jfrovich
    Member
    Posted 3 years ago #

    If i go to the plugin page

    I get

    DB Cache Reloaded Error: wpdb class is redefined, plugin cannot work!
    Previous definition is at /home/xx/public_html/x.com/wp-includes/wp-db.php:52.

    DB Cache Reloaded Error: DB Module (wpdb class) is not loaded. Please open the Options Page, disable caching (remember to save options) and enable it again. If this will not help, please check FAQ how to do manual upgrade. (i already did this)

  3. jfrovich
    Member
    Posted 3 years ago #

    I disabled and re enabled the plugin.
    Still getting errors.
    Good thing i only upgraded a test site.

  4. jfrovich
    Member
    Posted 3 years ago #

    I cleared the both caches and deleted and reinstall DB Cache Reloaded.

    Ill give the programmer time to correct it.
    OPS, sorry for the multiple posts, just noticed the EDIT button now. :(

  5. stevemagruder
    Member
    Posted 3 years ago #

    I'm experiencing the same problem. It appears that DBCR's extension/rewrite of WP's WPDB class isn't working because that class has been revised. Hopefully, the developer can figure out what needs to be done.

  6. inzaghi89
    Member
    Posted 3 years ago #

    Same for me. Waiting for solution... Hope they will fix this soon.

  7. dayer
    Member
    Posted 3 years ago #

    With "Wrapper mode" I haven't errors.

  8. itstimemma
    Member
    Posted 3 years ago #

    Mine is broken as well. Any ETA to an update? Thanks!

  9. sparklette
    Member
    Posted 3 years ago #

    I enabled the Wrapper Mode and there are no more errors in 3.1.

  10. stevemagruder
    Member
    Posted 3 years ago #

    Yes, wrapper mode works -- just tested. As wrapper mode is, per its description, "less efficient", hopefully the default mode will be fixed at some point.

  11. Neozinho
    Member
    Posted 3 years ago #

    Guys, simply DISABLE DB Cache Reloaded and click on "Save". After this, ENABLE the plugin again, click on "Save" and... voilá! The error's gone!

  12. stevemagruder
    Member
    Posted 3 years ago #

    I've already tried that, and I'm afraid that's not the case as far as I can tell. If you come back to DBCR page later, the error is still there.

  13. inzaghi89
    Member
    Posted 3 years ago #

    Yup, I can confirm that disabling and enabling did not help. After dashboard refresh it shows again error. At the moment I am using WP Super Cache and I think that it is better solution for now.

  14. Maxime CHEVASSON_Masamune
    Member
    Posted 3 years ago #

    @inzaghi89 > Wp Super Cache is caching your pages, DB Cache Reloaded is caching database access ; they're not doing the same caching and you should use them both ;)

  15. pbsbluejay
    Member
    Posted 3 years ago #

    Hi,

    I'm also having the same issue... "DB Cache Reloaded Error: wpdb class is redefined, plugin cannot work!"

    "Previous definition is at /home/pxxxx/public_html/xxxx.com/wp-includes/wp-db.php:52."

    I just upgraded to WP 3.1 and tried everything I could to get the DB Cache Reloaded plugin to work.

  16. nstoker
    Member
    Posted 3 years ago #

    looking forward to a 3.1-compatible upgrade!

  17. gordolake
    Member
    Posted 3 years ago #

    confirm that 1. disable DBcache 2. save 3.tick enable wrapper mode 4. save
    good to go.

    cheers

  18. Bert Loedeman
    Member
    Posted 3 years ago #

    @gordolake the plugin does function using 'wrapper mode'. Otherwise, it fails.

  19. pbsbluejay
    Member
    Posted 3 years ago #

    Just enable 'wrapper mode' and it will correct the problem. Login to WordPress and go to Settings >> DB Cache Reloaded. See Advanced' section below -- if the 'Wrapper Mode' is Disabled, then you need to enable it.

    To enable it, uncheck the 'Enable' box at top and click the 'Save' button. Look for 'Enable Wrapper Mode' in the 'Advanced' section below and click the box to enable it, then click the 'Save' button. That's it in a nutshell!

  20. vmalvrod
    Member
    Posted 3 years ago #

    The problem is about file/directory permissions when you update to 3.1 version.

    Change wp-content dir to 775 (permission)

  21. jfrovich
    Member
    Posted 3 years ago #

    Yes wrapper mode and file/directory permissions can fix it
    But i,m not about to MANUALLY do this on 60+ wp installs.

    Ill wait for the plugin to be fixed, (which is a TRUE fix),then upgrade those sites to wp 3.1

  22. brettbum
    Member
    Posted 3 years ago #

    agree w/ jfrovich.

    This has been a very good plugin, looking forward to the update.

  23. dubina
    Member
    Posted 3 years ago #

    same error
    wait for update

  24. Ivan Kristianto
    Member
    Posted 3 years ago #

    Hi i make patch for DB Cache Reloaded so it is working with WordPress 3.1
    Please download it on my blog at:

    DB Cache Reloaded Fix For WordPress 3.1

    Hope my patch help everyone.

    Thanks and Regards

    Ivan

  25. Ivan Kristianto
    Member
    Posted 3 years ago #

    Hi now my patch is available on WordPress repository.
    It available at:
    DB Cache Reloaded Fix

    Thanks

    Ivan

  26. stevemagruder
    Member
    Posted 3 years ago #

    I'm afraid the fix isn't working for me. I'm getting this error:

    Fatal error: Class 'dbrc_wpdb' not found in {site}\wp-content\db.php on line 96

  27. Ivan Kristianto
    Member
    Posted 3 years ago #

    Hi stevemagruder,
    i have update db-cache-reloaded-fix 2 days ago to fix that.
    Please update the plugin.

    Thanks

    Ivan

  28. dubina
    Member
    Posted 3 years ago #

    i installed DB Cache Reloaded Fix , activated but still get error
    DB Cache Reloaded Error: wpdb class is redefined, plugin cannot work!
    Previous definition is at /home/wp-includes/wp-db.php:52.

  29. Ivan Kristianto
    Member
    Posted 3 years ago #

    Please make sure you activate DB Cache Reloaded Fix instead of DB Cache Reloaded plugin

  30. stevemagruder
    Member
    Posted 3 years ago #

    The fix now works for me. Thanks Ivan!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic