WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: CyStats] Error after upgrade to WP 2.5 (7 posts)

  1. TechnoMom
    Member
    Posted 6 years ago #

    I'm using Cystats 0.9.0. Since upgrading to WP 2.5, I'm getting the error message:
    Warning: Invalid argument supplied for foreach() in /homepages/20/d162322745/htdocs/technomom/wp-content/plugins/cystats/includes/cystats.class.php on line 743

    It only shows up to users who aren't logged in.

    Any suggestions?

    http://wordpress.org/extend/plugins/cystats/

  2. barrydt
    Member
    Posted 6 years ago #

    I have Cystats 0.9.1, and I'm not getting an error. However, I was having trouble with the visual editor (couldn't see the toolbar to post anything), so I deactivated all of my plugins, and reactivated them one by one. It appears that the one that caused the error is CyStat - any time I activated that plug-in, it broke the visual editor interface.

  3. cywhale
    Member
    Posted 6 years ago #

    Hello.

    @TechnoMom: Just wrote you an email, the error you mention should be fixed in the developement version of CyStats ('other versions' in the download section).

    @barrydt: Does the disappearing toolbar-bug show up using IE7 only or in all browsers? Currently I do not know how CyStats can cause a bug in TinyMCE, does disabling javascript statistics in CyStats options help?

  4. cywhale
    Member
    Posted 6 years ago #

    @barrydt: According to another tester (thank you tommy) who had this issue this seems to be a problem with the javascript sorttable script (there's a bug mentioned about the script not working with IE7, http://www.kryogenix.org/bugs/sorttable/) - just comment out (just put a # in front of the line) the line echo '<script src="'.$url_js.'"></script>'; so the function cystats_css() at the bottom of plugins/cystats/cystats.php looks like this:

    function cystats_css() {
        $url = get_settings('siteurl');
        $url_css = $url . '/wp-content/plugins/cystats/admin/style.css';
        $url_js = $url . '/wp-content/plugins/cystats/includes/sorttable.js';
        echo '<link rel="stylesheet" type="text/css" href="' . $url_css . '" />';
        #echo '<script src="'.$url_js.'"></script>';
    
    }

    You will loose the ability to sort the statistics tables but cystats will work and so will the tinyMCE editor. Please tell me if that helps on your issue.
    Maybe sort feature will be dropped in next version of cyStats.

  5. barrydt
    Member
    Posted 6 years ago #

    Yes, that worked! Cystats is working and the editor is working also. Thank you for your help!

  6. barrydt
    Member
    Posted 6 years ago #

    Actually, let me update you on the situation - when I commented out the echo line as you noted, it worked for the visual editor for the posts; however, I tried to edit one of my pages (my 'About Me' page), and the same thing happened - no buttons on the visual editor at all. I'm not sure why it worked for the post editing and not the page editing - any ideas?

  7. cywhale
    Member
    Posted 6 years ago #

    Somwhere I read about disappearing buttons in WP >2.5 as a (unfixed) bug of WP - can you reproduce this de-/reactivating CyStats? Does it occur on all Browsers or IE7 only?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags