WordPress.org

Ready to get started?Download WordPress

Forums

CW Image Optimizer
[resolved] You are missing: opt-png, opt-gif. (7 posts)

  1. testandstart
    Member
    Posted 2 years ago #

    works with jpg but not with png and gif
    tried everything!
    the plugin is clearly broken!!

    http://wordpress.org/extend/plugins/cw-image-optimizer/

  2. Jacob Allred
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin isn't broken. This issue means you are missing required dependencies. The plugin can only work if you've installed all the jpg, png, and gif tools that make image optimization possible.

    Please check that you've installed all the dependencies listed on the installation page, and then reinstall littleutils.

  3. testandstart
    Member
    Posted 2 years ago #

    all the dependecies have been installed.
    the plugin IS broken
    sorry,

    my previeus post
    http://wordpress.org/support/topic/plugin-cw-image-optimizer-you-are-missing-opt-png-opt-gif-bug?replies=3

  4. Jacob Allred
    Member
    Plugin Author

    Posted 2 years ago #

    Again, the plugin is not broken. I'm personally using it on dozens of sites on dozens of servers without any issues, including normal WP installations and network installations.

    Based on your other post, I'd recommend re-installing the dependencies using the instructions I've provided: http://wordpress.org/extend/plugins/cw-image-optimizer/installation/

    You can do some additional troubleshooting by testing the optimization manually, using commands like below via SSH, where somepicture.gif is a gif on your server:
    opt-gif somepicture.gif

  5. testandstart
    Member
    Posted 2 years ago #

    sorry,
    It's working perfectly well! ;-)

  6. Jacob Allred
    Member
    Plugin Author

    Posted 2 years ago #

    No worries. Glad you were able to get it working!

  7. ls41
    Member
    Posted 2 years ago #

    I have the same error.

    CW Image Optimizer requires littleutils. You are missing: opt-png, opt-gif.

    I tried the installation instructions twice and ln commands and the links already exists.

    What could be missing?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic