WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Custom widgets] plugin not working for static posts page (8 posts)

  1. herko
    Member
    Posted 4 years ago #

    I love Slayers Custom Widgets plugin, it enables me to put widgets on specific pages. There's just one HUGE issue with it that makes it difficult for me to use properly.
    When setting a static 'Blog' page as the posts page, widgets you set to show on that page do not show up. It works fine on other pages and single post pages. Just not the static posts page.

    Can anyone look into this, pretty please?

    I've searched but it seems support for this plugin has died. The comments on the plugin website all state the same problem, as well as here in the forums, but for the past 8 months Slayer hasn't provided any support whatsoever.

    This is too bad, because WordPress relies on quality plugins as much as it does on a stable core. It's awesome software ad I love it, but when people create stuff for wordpress it should be easier to get support for them. Oh, and I *know* it's free, but open source isn't about gratis, it's about freedom. So it's about the freedom to get support from someone else, as the code is freely available.

  2. chooseamc
    Member
    Posted 4 years ago #

    Sounds like we're experiencing the same thing. I use my blog post page as my home page and have added several other pages. Using Custom Widgets, whenever I remove a widget from a different page, it removes it from the blog (home) page too. Even tried creating a separate "named" page for the posts and setting it as the home page. Still the same result.

    I've seen other messages both here on on Widget Logic's page that seem to have similar problems.

    I did use this on another site where the blog posts were news bits on a page called News, which isn't the home page, and it worked fine.

    Not sure why the problem with the home page. Hoping Slayer comes out of the woodwork and sheds some light!

  3. herko
    Member
    Posted 4 years ago #

    I did use this on another site where the blog posts were news bits on a page called News, which isn't the home page, and it worked fine.

    That's where it fails for me, oddly enough. I have a static page called 'news and blog', and set is as my posts page. And I added 2 widgets to show on that 'news and blog' page, and on all posts pages, but they do not show up.

    My home page is another static page, and I can add widgets to that page only just fine..

    I'm using WP 2.8.6.

  4. seleniumgirl
    Member
    Posted 4 years ago #

    Hi herko and chooseamc-- I've sent TS an email on this matter, as I am having the same issue. I've inquired about a quick CSS patch and I'll let you know if he responds and what he has to say. Happy new year!

  5. herko
    Member
    Posted 4 years ago #

    It seems I have a solution to this issue: set the widgets to show on the 'home page' (checkbox in the list at the bottom of the page) for those widgets you want to show on the static posts page ou set in your WP settings.

    And Happy New Year to you too :-)

  6. seleniumgirl
    Member
    Posted 4 years ago #

    Oh, that's just an excellent and easy fix. I wonder why I didn't play around with those checkboxes sooner. Thanks tons, herko!

  7. SJdelsim
    Member
    Posted 4 years ago #

    Herko.. it seems i am experiencing the same issue.. i have a static "homepage" and wish to display posts of category "news".. (using wp2.9.2 and ataluha theme) i have created a new main page sidebar for the job and placed recent posts widget in it.. so far all good.. previously using widget logic and now custom widget i can have the widget loaded exclusively on the homepage..

    However when i choose only the "news" category (indeed tried with tags as well) to display posts for it doesn't do the filter..

    Could you elaborate on the solution

    ****set the widgets to show on the 'home page' (checkbox in the list at the bottom of the page****

    Which page is this set on?

    ****for those widgets you want to show on the static posts page ou set in your WP settings****

    which WP setting?

    Hope you can help.. probably be useful for others!!

  8. GeekSpecialties
    Member
    Posted 4 years ago #

    herko - thanks so much. I was having the same issue with widgets not showing on static post page and that was the solution.

Topic Closed

This topic has been closed to new replies.

About this Topic