WordPress.org

Ready to get started?Download WordPress

Forums

Custom Taxonomy Columns
Columns do not appear (3 posts)

  1. web559
    Member
    Posted 2 years ago #

    I've installed the plugin on my site (3.3b3), and it has no effect on my post list in the admin. No custom taxonomy columns appear. This is on post type of 'post', which has several fully functioning and public taxonomies attached to it.

    Custom taxonomies are absent from Screen options as well, so it's not that they're hidden.

    Any idea what the problem is?

    I don't think this would be the problem, but here's an example of my standard taxonomy registration code. Like I said, the taxonomies work fine.

    $labels = array(
    	'name' => _x( 'Features', 'taxonomy general name' ),
    	'singular_name' => _x( 'Feature', 'taxonomy singular name' ),
    	'search_items' => __( 'Search Features' ),
    	'popular_items' => __( 'Popular Features' ),
    	'all_items' => __( 'All Features' ),
    	'edit_items' => __( 'Edit Features' ),
    	'update_item' => __( 'Update Features' ),
    	'add_new_item' => __( 'Add New Feature' ),
    	'new_item_name' => __( 'New Feature' ),
    	'separate_items_with_commas' => __( 'Separate features with commas' ),
    	'add_or_remove_items' => __( 'Add or remove features' ),
    	'choose_from_most_used' => __( 'Choose from the most used features' ),
    	'menu_name' => __( 'Features' ),
    );
    $args = array(
    	'labels' => $labels,
    	'public' => true,
    	'show_in_nav_menus' => true,
    	'show_ui' => true,
    	'show_tagcloud' => true,
    	'hierarchical' => true, // this makes it hierarchical in the UI
    	'rewrite' => array( 'hierarchical' => true ), // this makes hierarchical URLs
    	'query_var' => true,
    );
    register_taxonomy('feature', $allposttypes, $args);

    http://wordpress.org/extend/plugins/custom-taxonomy-columns/

  2. bobbydonovan
    Member
    Posted 1 year ago #

    Two small modifications were required to make this work for me.

    On both lines 56 and 92 of the core plugin file, change:

    $postax = get_taxonomies( array( '_builtin'=>false,'object_type'=>array( $post_type ) ), 'objects' );

    to the following

    $postax = get_object_taxonomies( $post_type , 'objects' );

  3. thorirv
    Member
    Posted 1 year ago #

    Nice BobbyDonovan!

    Glad I camea across this thread, or I would have spend the rest of the day trying to figure this out..

    Best
    Th

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic