WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Widget
[resolved] Conflict with Gravity Forms (10 posts)

  1. cwulff
    Member
    Posted 3 years ago #

    Conflict with Gravity Forms in the modal window on the post edit page.

    http://cl.ly/201C3x340H3r1z1e053Q

    Clicking the forms link opens the Gravity Forms header, but replaces the content with yours.

    From their support forum:

    This is a bug on their end. They copied our code to create their shortcode wizard and they didn't change the ID of the window they open. They need to change the ID of the modal window they open. They hijack ours because they used the same ID that we use because they copied our code but didn't completely customize it for their needs.

    I think they meant this as kindly as possible. :)

    http://wordpress.org/extend/plugins/custom-post-widget/

  2. Johan van der Wijk
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for letting me know! I will change this asap!

  3. Johan van der Wijk
    Member
    Plugin Author

    Posted 3 years ago #

    This issue has been fixed. If you are experiencing this issue, please reinstall the plugin.

  4. katart17
    Member
    Posted 3 years ago #

    I reinstalled the plugin and still have am experiencing this issue. Any ideas?

  5. katart17
    Member
    Posted 3 years ago #

    Actually my issue might be a little different. When both Gravity Forms and Custom Post Widget plugins are activated, Gravity forms completely takes over the CPW plugin. The CPW custom post type disappears.

  6. katart17
    Member
    Posted 3 years ago #

    Johan, has this issue been resolved? I am still having the problem on my site.

  7. Johan van der Wijk
    Member
    Plugin Author

    Posted 3 years ago #

    @katart17 Please check if you are running the most recent version of the plugin. The function on line 3 of popup.php should be called function add_content_block_popup() and not function add_mce_popup().

    I have tested this on a WordPress installation with both the Custom Post Widget plugin and the Gravity Forms plugin (1.5.2.8) installed and could not replicate your issue.

  8. katart17
    Member
    Posted 3 years ago #

    @johan thanks for the reply. After deactivated all plugins and turning them on one at a time, I noticed that the conflict is actually with the Easy Content Types plugin http://pippinsplugins.com/easy-content-types/.

    I will contact him to see if he can help with this and please let me know if you have any ideas.

    Thanks

  9. katart17
    Member
    Posted 3 years ago #

    @johan

    I received a solution from Pippin to the conflict. He said I had to change the Menu Position number and that solved it.

  10. Johan van der Wijk
    Member
    Plugin Author

    Posted 3 years ago #

    Excellent, I am glad this is solved now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic