WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type Permalinks
Nothing Found in custom taxonomies (3 posts)

  1. Quelizinha
    Member
    Posted 2 years ago #

    Hello,

    I am experiencing a conflict between the plugin "Permalinks Custom Post Types" and the plugin "WP Business Directory" from CodeCanyon. This plugin creates a custom post type and two taxonomies, one like tags and another like category.

    When I click on links in anyone terms of both taxonomies the result is "Nothing Found", but is not a 404 page, because the archive page appears with the title. But it is as if there were no posts tagged with those terms. As if it did not find the posts. Does anyone have any idea of what may be the problem?

    http://wordpress.org/extend/plugins/custom-post-type-permalinks/

  2. Quelizinha
    Member
    Posted 2 years ago #

    I have other custom post types and lots of custom taxonomies (created with the plugin "Custom Post Types UI", and the problem occurs only with de taxonomies created by this plugin "WP Business Directory" . I think it is a filter or query problema, but I don't know what.

  3. BriceLucas
    Member
    Posted 1 year ago #

    Hi Quelizinha!

    Try removing the following line (line 161 i believe) from the custom-post-type-permalinks.php file:

    $wp_rewrite->add_rewrite_tag( "%$taxonomy%", '(.+?)', "$taxonomy=portfolio_category" );

    Then "save your permlinks" in the WP admin, and check your taxonomy archive pages.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic