WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Permalinks
[resolved] compatibility with Custom Post Type UI (7 posts)

  1. taeke
    Member
    Posted 3 years ago #

    I noticed that the custom posts permalink plugin only works (or adds its section to the Permalink settings page) when the custom post types are manually added via the functions.php file. Is that correct? I'm playing around with the Custom Post Type UI plugin by WebDevStudios and the custom post type permalink section doesn't seem to work..

    http://wordpress.org/extend/plugins/custom-post-permalinks/

  2. John P. Bloch
    Member
    Plugin Author

    Posted 3 years ago #

    Hi taeke,
    I looked into this, and it's actually a bug in the way that Custom Post Type UI registers post types. They should be registering 'hierarchical' as a boolean, but it's a string instead.

    If anybody in charge of Custom Post Type UI sees this, it's on line 108. If you change it to look like this:

    'hierarchical' => get_disp_boolean( $cpt_post_type["hierarchical"] ),

    Then everything works perfectly.

  3. taeke
    Member
    Posted 3 years ago #

    great, thanks!

  4. Brad Williams
    Member
    Posted 3 years ago #

    Fixed in the latest release: v.0.6.2

  5. kato
    Member
    Posted 3 years ago #

    How should we set up custom permalinks to work with Custom Post Type UI?

    My URLs are currently showing up as
    domain.com/?namespace_custom_post_type=title

    yes, the equals sign in actually in there.

    I set up rewrite in CPTUI to eliminate the namespace but it's still there. I'll check the FAQ.

  6. kato
    Member
    Posted 3 years ago #

    a google search later (that sounds like a long time ago, doesn't it?)

    it turns out, someone modified version .6 of CPTUI to do this. Brad, have you seen this?

    http://thepanz.netsons.org/post/wp3-custom-post-types-and-permalinks

    Should I use an older version with the mod?

  7. kato
    Member
    Posted 3 years ago #

    I just wasted an hour of my life investigating other plug ins to do this before discovering it works just fine in Brad's Custom Post Types UI

    IF YOU SET HIERARCHICAL TO TRUE!!!!

    If those little help question marks to the right were working in firefox I probably would have known that.

    AHHHHHHHH!

    Executive summary: set hierarchical to true, permalinks work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic