WordPress.org

Ready to get started?Download WordPress

Forums

Custom Field Suite
[resolved] 3.3 Breaks WYSIWYG Editor Field (9 posts)

  1. thecorkboard
    Member
    Posted 2 years ago #

    Looks like you might have a bug with your WYSIWYG editor field on 3.3 installs. I don't see the editor, just a textarea.

    Thanks!
    ~Kyle~

    p.s. posted at uprootus as well - wasn't sure what would be best.

    http://wordpress.org/extend/plugins/custom-field-suite/

  2. logikal16
    Member
    Plugin Author

    Posted 2 years ago #

    Alright, give the latest update (1.2.5) a try.

    Reference:
    http://uproot.us/forums/questions/2/3-3-conflictwysiwyg-editor/

  3. thecorkboard
    Member
    Posted 2 years ago #

    Did a fresh install of 3.3 with the 1.2.5 CFS with no luck; still just a textarea.

  4. thecorkboard
    Member
    Posted 2 years ago #

    Addendum: in my most recent test I just added a field group with a wysiwyg field to the "Posts" - not a new custom post type.

  5. Bage
    Member
    Posted 2 years ago #

    I couldn't get the WYSIWYG editor work either on the latest version (1.2.5)

  6. logikal16
    Member
    Plugin Author

    Posted 2 years ago #

    I just did a fresh install and wasn't able to reproduce the issue.

    1. Could you list all active plugins?
    2. Could you try re-downloading the CFS files?

    Worst case, I may need to ask for some login information (unless you're working on your local machine).

  7. thecorkboard
    Member
    Posted 2 years ago #

    Hey there-

    So I downloaded and installed the latest on (another) fresh install with complete success. I then went to my local dev site, deleted whatever version of CFS I had, installed a fresh copy of CFS, removed all plugins, removed all themes (minus twentyeleven), and created a new site (I'm working in MultiSite), created a new field group with a WYSIWYG field - no luck. Still just a textarea. I also cleared my browser without effect; also tried a different browser, no dice.

    I also went back to my CFS test that worked and enabled MultiSite; it still worked.

    I'm miffed.

    Here's a screencast that shows it's not working plus my list of plugins. I'll see if I can't get it live so that you can play around: http://screencast.com/t/ksxwZvlr

  8. thecorkboard
    Member
    Posted 2 years ago #

    Follow up:

    Was inspecting an "add post" where a WYSIWYG field should be and saw this:

    GET http://learn.thecorkboard.org/course-builder/wp-includes/js/tinymce/themes/simple/editor_template.js?ver=345-20111127 404 (Not Found)
    wp-tinymce.php:2
    
    Failed to load: http://learn.thecorkboard.org/course-builder/wp-includes/js/tinymce/themes/simple/editor_template.js

    Not sure why it's looking for these as there is no "themes/simple" directory packaged with 3.3. I deleted TinyMCE to see if that was the issue; it wasn't.

    I went in and deleted CFS, checked the error again on the same page and it didn't exist. So, I reinstalled it - all through the plugin manager - and now everything is just dandy!

    Odd that something was lingering about with all the checking I did. I guess you can close this thread as resolved.

    Thanks as always!

  9. logikal16
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to hear you solved it (that screencast was helpful too).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic