WordPress.org

Ready to get started?Download WordPress

Forums

Custom Field Bulk Editor
[resolved] Fatal error: Out of memory (9 posts)

  1. ronrrico
    Member
    Posted 2 years ago #

    Hello, I'm getting the following error:

    Fatal error: Out of memory (allocated 116391936) (tried to allocate 43 bytes) in /home/xxxxxxx/public_html/wp-includes/meta.php on line 567

    Anyone know why? or how I can fix this?

    Thanks in advance

    Ronnie

    http://wordpress.org/extend/plugins/custom-field-bulk-editor/

  2. ronrrico
    Member
    Posted 2 years ago #

    I wanted to that I enabled the php.ini
    Settings:

    max_execution_time = 90
    max_input_time = 300
    memory_limit = 256M
    upload_max_filesize = 64M

    Still get the error :-(

  3. sparkweb
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmm.... do you have an exceptionally large number of posts? Are you trying to load a lot of data once? This error is basically saying that the web server ran out of memory when it was trying to accomplish the task of creating an array. The code in question within the the WP core is:

    if ( !isset($cache[$mpid][$mkey]) || !is_array($cache[$mpid][$mkey]) )

    So my guess is that you possibly are attempting to upgrade a large number of posts at once? Maybe you could try a few different tests or types of updates and see if it make a difference.

    FWIW, the only other time I've run across this type of error was when dealing with images in NextGEN that were the wrong DPI and was sending the server in a loop.

  4. ronrrico
    Member
    Posted 2 years ago #

    It happens if I try to edit 1 or 100 products.
    The error comes up 5 seconds after submitting.
    Could it be another plugin conflicting?

    Thanks for the reply...

  5. sparkweb
    Member
    Plugin Author

    Posted 2 years ago #

    General troubleshooting practices dictate that you disable all other plugins and see if it solves the problem, and if it does, then start adding them back in one by one to see if that solves the problem.

    You could also try doing this in your wp-config.php:

    define('WP_MAX_MEMORY_LIMIT', '256M');

  6. ronrrico
    Member
    Posted 2 years ago #

    No change, thanks for the advice.
    I'm looking to get a project going on a site. Let me know if you are interesred.

  7. sparkweb
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry you couldn't get it going. Not sure what could be going on. Sounds like it is likely an environmental thing, though.

    For inquiries on other work, feel free to email me: web -at- sparkweb (dot) net. Thanks....

  8. ronrrico
    Member
    Posted 2 years ago #

    I'll send you some details in a few...

    Thanks again....

  9. ronrrico
    Member
    Posted 2 years ago #

    Hello Dave, did you ever get the details email?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic