WordPress.org

Ready to get started?Download WordPress

Forums

Custom Content Type Manager
WYSIWYG Doesnt Show Format Controls (6 posts)

  1. WebmistressM
    Member
    Posted 2 years ago #

    Hmm... it appears that while I can create a custom content field that is a formatted/wysiwyg box, Im still unable to actually use the controls.

    I created the field in my custom content type. When I add a post of that product type, I can enter in any sort of text I want within this WYSIWYG text field. However, the controls for formatting do not show up.

    I did check and see if the user Im logged in with has its setting set to "disable visual editor" in case that was the problem. Seems that doesnt matter.

    I did notice a place to add extra attributes (columns, rows, font size, etc..) which may be where I can set a "minimum" on it, according to the documentation. Would this let my format control show up?

    http://wordpress.org/extend/plugins/custom-content-type-manager/

  2. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Ah, I think I know what's going on... does your content type have the main "Content" field enabled? If not, then WordPress hides the necessary javascript. There was a bug about this previously, and I fixed it for an earlier version of WP, but it seems it's back with 3.2.

    Try editing your content type, going to the Fields tab, and checking the "content" field, and then see if your WYSIWYG field behaves as expected.

  3. WebmistressM
    Member
    Posted 2 years ago #

    Yup. Thats the problem. So, for now, I am gonna have to have the content field and this secondary field in order to get the WYSIWYG controls for my custom field.

  4. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    I'm gonna file the bug for this... it looks like WP has changed how it implements the WYSIWYG, probably they're trying to phase out the deprecated thickbox JS...

    Thanks for bringing it to my attention.

  5. WebmistressM
    Member
    Posted 2 years ago #

    You are welcome.

  6. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    I fixed this. The fix will be available http://wpcctm.com/cctm-dev.zip

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic