WordPress.org

Ready to get started?Download WordPress

Forums

Custom Content Type Manager
Custom Fields icons not showing, nor text (8 posts)

  1. amityweb
    Member
    Posted 2 years ago #

    When I go to create a custom field, I get a row of grey squares and no images to represent the fields. It also does not show the type of field (radio, text, etc). So I have to hover over each one and see the URL to know which is which. Is this supposed to be like this? Your video shows some images.

    Thanks

    http://wordpress.org/extend/plugins/custom-content-type-manager/

  2. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Sounds like your image paths are broken. I had an issue with this previously that cropped up with certain server configurations (namely, the server reported the incorrect directory path).

    Can you provide more details, or ideally, provide me access to your server so I can look around? I love opportunities to look at this on other servers because my testing environment isn't necessarily representative of what everyone else is running.

    I think you can message me privately via these forums, or you can contact me via the email address listed on http://www.fireproofsocks.com/contact/

    Thanks!

  3. amityweb
    Member
    Posted 2 years ago #

    Thanks for the reply, but I would rather not give server access sorry.

    Its a completely fresh latest WordPress installation (v. 3.2.1) and then I added this plugin and nothing else. I have not modified anything.

    Where would these paths be stored so I can check?

    Thanks

  4. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    I understand, but it's much more difficult to troubleshoot when I can't reproduce the problem. I should have verified that you are using the most recent version of the plugin (current stable is 0.9.3.3). Download the latest version of the plugin: http://wpcctm.com/cctm-dev.zip. There was a similar issue with version 0.8.9 (see this ticket), so make sure you've upgraded.

    What is the path to the broken images? Also, are the paths broken on the page that lets you define the custom field, or only when all possible custom-fields are listed?

    Most of this comes down to the get_custom_icons_src_dir() function inside of includes/CCTM.php. Many other bits rely on that one function

    Hope that helps.

  5. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    One other thing to watch is to make sure that you've installed the plugin in a directory named custom-content-type-manager (inside wp-content/plugins). After installing the dev version, I realized that some paths may break if the directory is not properly named.

  6. amityweb
    Member
    Posted 2 years ago #

    Thanks a lot for your support on this, unfortunately my customer has decided to go with Expression Engine now... I gave them both WordPress and EE to try and they decided on EE (nothing to do with your plugin). Your plugin works great in my tests apart from this minor issue.

    But now I know about it I may use it again in the future when I have a customer that requires Content Types and wants WordPress. I am sure there will be due to EE costs.

    Thanks

  7. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    No problem. EE is a much better system in a lot of ways... much better architecture, and the cost is reasonable for what you get I think.

  8. amityweb
    Member
    Posted 2 years ago #

    I like the way in EE you start with nothing and build from the ground up, whereas WordPress, Joomla and Drupal you start with something and have to work your way down to streamline them!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic