WordPress.org

Ready to get started?Download WordPress

Forums

Custom Contact Forms
Can't delete a fixed field? (5 posts)

  1. wpress2010
    Member
    Posted 1 year ago #

    I successfully installed and configured your plug-in. Very simple.

    But, I need to remove one of the Fixed Fields - the "Your Website" field, specifically. I checked the box next to it in the Fields tab under the Manage Fixed Fields heading, but the Bulk Actions dropdown only contains a choice for Save, not Delete, as in the Manage User Fields area.

    I could hide this field with CSS easily enough, but can't figure out why I can't delete it in the plug-in configuration. Many visitors to the site on which I am working don't have websites, and although I can set the field to Not Required, I just want to remove it.

    TIA for your help!

    http://wordpress.org/extend/plugins/custom-contact-forms/

  2. markmaio
    Member
    Posted 1 year ago #

    I am also trying to remove this field (Your Website). Can anyone offer me any help?

    Thanks,

    Mark

  3. lenamtl
    Member
    Posted 1 year ago #

    For the fields you don't want to use:
    Using the latest version you can detach field you don't need in Form Options see latest part Attached Fields:

    If you want to completely hide this field from the admin section,
    check in the database and remove the entry from
    customcontactforms_fields
    You will probably need also to edit php files of the plugin so make sure you a have a full backup of the script and database before modifing this. The first solution should do the job.

  4. wpress2010
    Member
    Posted 1 year ago #

    Unfortunatly, I have found that despite having removed the Your Website as an attached field, Saving, and then checking the form, the field still persists.

    I have cleared my browser cache, so that isn't the problem.

  5. wpress2010
    Member
    Posted 1 year ago #

    CSS-only solution (CSS3), works only in modern browsers, but OK for my purposes. Hides the unwanted field and closes up the space where the website field would be:

    body.page-id-48 form div:nth-child(3) {
    display:none;
    }

    You can find the body class you need from just looking at the code on the page when it displays. I added these 2 lines to my theme's custom CSS file. HTH

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic