WordPress.org

Ready to get started?Download WordPress

Forums

Custom About Author
[custom_author=user] Not working on pages (11 posts)

  1. Lenny
    Member
    Posted 2 years ago #

    Hello,

    Great plugin!

    I have a _real_ user that is a "subscriber" role and I created him as a custom user as well. so I cannot make it the author of a page, but your plugin sounds like it would using the shortcode - or is it?

    As of now I've been unable to get the "about author" info to show up on a page. Is this plugin meant for posts only, or have I done something wrong?

    Thanks!

    http://wordpress.org/extend/plugins/custom-about-author/

  2. edwinkwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hi LBSources,

    I had intentionally disabled displaying of the about author info on pages.

    The rationale behind that was that I thought the plugin would only be used on posts and I didn't want users to have to manually disable displaying of the info on all pages.

    I will put a change into the next release of the plugin to have the shortcode work on pages too.

    Thanks for highlight this issue.

    Cheers,

    Edwin

  3. Lenny
    Member
    Posted 2 years ago #

    Hey edwinkwan - Glad to know I'm not the one going crazy :)

    I could get it to work on posts, but not pages..

    Any idea how I can make this work in the meantime while we wait for the next release?

    Thanks again!

  4. Lenny
    Member
    Posted 2 years ago #

    edwinkwan Any luck on getting this into the new release soon?

  5. edwinkwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hi LBSources,

    I've just submitted the new release, which has your fixes. It's determined by a global configuration in the Custom Authors settings page.

    Thanks for your patience.

  6. Lenny
    Member
    Posted 2 years ago #

    Hey edwinkwan Thanks for the new version. I just installed it. Works OK, but I'm unable to add the _just_ the shortcode to a page to display author information. Seems I have to add the custom field in order to use the shortcode. I'm sort of OK with this, but if I have to use the custom field, then it'd be great to have an option to have the author info at the top or the bottom of a post/page. I was hoping to use the shortcode wherever I liked cause It wouldn't confine me to a specific static position.

    I know you may have worked hard on this new release, but what do you think about my dilemma? For now, I can deal with this :)

    Thanks again for your diligence and hard work on this plugin :)

  7. Lenny
    Member
    Posted 2 years ago #

    Hi one more thing - it seems like I can't add users anymore. I receive the error: Error Adding Custom Author! anytime I try to create a user.

  8. edwinkwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hi LBSources,

    You should be able to use the shortcode on pages.
    [custom-author] or [custom-author=some-username]

    As for the error with adding users. Thanks for highlighting that problem. I've released 1.4.1 to address that issue.

  9. Lenny
    Member
    Posted 2 years ago #

    Hi edwinkwan thanks for that.

    A few things I noticed:
    1. I cannot use the shortcode if I only create the custom author without the user being a real WP user. Nothing shows up.

    2. I cannot use the shortcode unless #1 is resolved and unless I set the custom-author custom field on the page. But this creates double custom author boxes - 1 where I use the shortcode and the other at the bottom of the post.

  10. edwinkwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hi LBSources,

    I just tested it on my development site and it works.
    This is what I did

    1. Create new custom author with username=test
    2. In the page, I added the shortcode [custom_author=test]

    It worked for me. Was that what you did too?

  11. Lenny
    Member
    Posted 2 years ago #

    Hi edwinkwan..

    I did the same thing, but no author information shows up. I have to add the custom-author attribute which then causes the info to come up twice (top/bottom).

    Seems like I cannot get it to work otherwise :(

    Thanks for the help! Really appreciate it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic