WordPress.org

Ready to get started?Download WordPress

Forums

Current Weather
[resolved] Adding Shortcode causes Page Content to Not Display (5 posts)

  1. kmcgrathdesign
    Member
    Posted 2 years ago #

    When I install and activate the plugin, then add the following shortcode to my page (and republish), all of the content disappears from the live page, leaving only the post heading. The weather also does not display.

    Here's the shortcode I'm using:

    [current_weather location="91355"]

    And here's the page (yes, it intentionally has a blank template, because we aren't finished creating the layout yet):

    http://174.129.36.66/visitsantaclarita/

    I didn't customize the CSS for the plugin at all; I just did the steps above. I put the shortcode at the end of the page content.

    I tried deactivating each of the other plugins I am using on this site and still had the same issue. I've also tried activating different themes, but this page doesn't work in any of them when the shortcode is on the page.

    Am I doing something wrong?

    http://wordpress.org/extend/plugins/current-weather/

  2. mmattner
    Member
    Plugin Author

    Posted 2 years ago #

    I just used the exact shortcode you gave above multiple times in a page template without any issues: http://sandbox.mikemattner.com/lorem-ipsum/

    It is showing up in my sandbox environment there in various contexts, and on other WordPress installs. I'm actually pretty stumped on this one, as I've tried to reproduce the problem without 'success.' I'm not entirely sure what is missing.

    What version of WordPress are you currently using? What are you using for your template as of right now? Something proprietary or a framework? Would turn on WordPress debugging, reload the link you gave me and let me know what errors pop up? That might point me in the right direction.

  3. kmcgrathdesign
    Member
    Posted 2 years ago #

    Thanks for the quick response! That site is using a home-grown theme that's still in progress and is being worked on heavily at the moment... I set up the plugin on a different site in the same WordPress install that isn't currently being developed so I could play around with it more. We're using WP 3.4.1, and this site is using the TwentyEleven theme.

    http://174.129.36.66/green/

    Your Debug tip did the trick - below is the error output. Based on this I set the /wp-content/plugins/current-weather/includes/cache/ folder to 777 and now it works fine!

    Warning: file_put_contents(/wp-content/plugins/current-weather/includes/cache/cache-weather-12796000.xml): failed to open stream: Permission denied in /wp-content/plugins/current-weather/includes/class.wp_current_weather.php on line 138

    Warning: file_get_contents(/wp-content/plugins/current-weather/includes/cache/cache-weather-12796000.xml): failed to open stream: No such file or directory in /wp-content/plugins/current-weather/includes/class.wp_current_weather.php on line 141

    Notice: Trying to get property of non-object in /wp-content/plugins/current-weather/includes/class.wp_current_weather.php on line 147

    Fatal error: Call to a member function children() on a non-object in /wp-content/plugins/current-weather/includes/class.wp_current_weather.php on line 147

  4. kmcgrathdesign
    Member
    Posted 2 years ago #

    Just reactivated the plugin on the original site and it's working now. Modifying the folder permissions on /wp-content/plugins/current-weather/includes/cache/ was all it needed!

    Thank you again for your help.

  5. mmattner
    Member
    Plugin Author

    Posted 1 year ago #

    Glad I could point you in the right direction and thanks for you using my plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.