WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: CubePoints Youtube Video Module] Videos Not Displaying (7 posts)

  1. Drymonema
    Member
    Posted 2 years ago #

    I have many YouTube videos embedded on my site using the [cp_youtube id=""] shortcode. When I upgraded to WordPress 3.4, they all disappeared. The shortcode is still in the post when I edit it, but nothing shows up in the published post. I have up-to-date versions of CubePoints and the module, and am using the Suffusion theme version 4.2.2

    What I have tried:

    - Switched to Twenty Ten theme

    - Disabled all plugins and enabled CubePoints only

    I would like to get this fixed so my readers can earn points for watching videos. Thank you in advance for any help.

  2. Drymonema
    Member
    Posted 2 years ago #

    My site is http://bloodsuckinggeek.com/ if that helps. One of the posts that is supposed to have videos is http://bloodsuckinggeek.com/best-unknown-horror-movies/.

  3. pixelartist
    Member
    Posted 2 years ago #

    Hey Dry,

    i just have installed the plugin cubepoints and wondered how the integration with the youtube module will work.
    I have the latest WordPress and all updated Plugins - and encountered exactly your problem - no video showed up.

    But tracing the error lead me to this quick fix:

    Find the youtube.php file in /plugins/cubepoints/modules/youtube.

    Check line 76:

    $video = '<script type="text/javascript">

    replace with:

    $video = '
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
    <script type="text/javascript">

    This change will load the swfobject lib from google and reenable your video. This is a dirty hack, i hope the original author reads this and fixes it properly.

  4. Drymonema
    Member
    Posted 2 years ago #

    Thank you so much pixelartist! That works just fine. I'm not sure what a 'dirty hack' is so I'll just go with it and hope that cubepoints fixes this problem with their next update.

  5. Jonathan Lau
    Member
    Posted 2 years ago #

    I do not seem to have any problems with using the existing code.
    Could you tell me the browser you are using as well?

  6. hkcharlie
    Member
    Posted 1 year ago #

    I have the same problem.
    (and the hack doesn't seem to be working for me)

  7. TribalDancer
    Member
    Posted 1 year ago #

    For me the videos are showing up fine. But no points are being awarded after watching, even all the way through. Hrmm...

Topic Closed

This topic has been closed to new replies.

About this Topic