WordPress.org

Ready to get started?Download WordPress

Forums

Crayon Syntax Highlighter
[resolved] [crayon-4fabb9a321161/] instead of code (18 posts)

  1. TIgor4eg
    Member
    Posted 2 years ago #

    Instead of showing code there is only tag
    [crayon-4fabb9a321161/]

    Instead of such code
    <pre class="lang:default decode:true " >include /etc/nginx/conf.d/*.conf;</pre>

    Example page.

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

  2. TIgor4eg
    Member
    Posted 2 years ago #

    1.9.3 version works fine.
    1.9.4 does not work.

  3. nickelfault
    Member
    Posted 2 years ago #

    Ahhhhh I'm having this problem too.

  4. nickelfault
    Member
    Posted 2 years ago #

    Rolled back to 1.9.3.

  5. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Investigating now, also you can set the language to Apache for the code on your site I believe. Could you provide the name of the theme?

  6. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    I think it's fixed, could you replace the existing file (after upgrading to 1.9.4) with this?

    http://dl.dropbox.com/u/33811812/Crayon/minor/crayon-syntax-highlighter-1.9.4-minor-2.zip

  7. nickelfault
    Member
    Posted 2 years ago #

    Didn't seem to fix it for me, do I need to do anything after replacing that file?

  8. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    No, you could reset the settings but it should just work. Could you share a URL?

  9. nickelfault
    Member
    Posted 2 years ago #

  10. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm, and do you have a copy of the theme so I can debug it locally?

  11. nickelfault
    Member
    Posted 2 years ago #

  12. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    How about this:

    http://dl.dropbox.com/u/33811812/Crayon/minor/crayon-syntax-highlighter-1.9.4-minor-3.zip

    Seems the theme doesn't trigger a the_excerpt filter.

  13. nickelfault
    Member
    Posted 2 years ago #

    Seems like it's working now! Thanks for your hard work man.

  14. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Great, thanks!

  15. TIgor4eg
    Member
    Posted 2 years ago #

    That fix worked for me to.

  16. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Good to hear :)

  17. RSixCookie
    Member
    Posted 2 years ago #

    like i sent in my mail, nice work, but 1.9.3, 1.9.4 all minors and now the brand new 1.9.5. is not working - i have the issue like the first poster here, just the ID ... but in the extended article its working.

    regards R6

  18. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    For others people having this issue:

    Your theme is being naughty. Find where it prints the content/excerpt on that page in the PHP and make sure to add this line before printing:

    $output = apply_filters('the_content', $output);

    This ensures that the content can be filtered by plugins, such as Crayon. Otherwise, Crayon detects and creates the code but can't replace those funny looking tags in the content.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic