WordPress.org

Ready to get started?Download WordPress

Forums

Crayon Syntax Highlighter
[resolved] Blank output & Coffeescript feat. request (5 posts)

  1. unDavide
    Member
    Posted 1 year ago #

    Hi,
    I'm using WP 3.4.2, Standard Theme 3.0.2 and Crayon 1.12.1.
    For some reason the following code (just as an example, it doesn't work no matter what I type):

    <pre class="theme:twilight height-set:true width-set:true lang:js decode:true">#include "components/core-min.js"
    #include "rollups/sha1.js"
    #include "rollups/aes.js"
    #include "components/enc-base64-min.js"
    #include "components/enc-utf16-min.js"
    var w = function (s) {
    $.writeln(s); // equivalent to console.log()
    }</pre>

    Gives issues:
    1. When I'm in Draft mode, the post preview doesn't show the code but this line:
    [crayon-50795e00c14e3/]

    2. When I publish the post, it shows the Crayon box with a single, empty line 1.

    You can find my plugin settings here:
    http://www.freeimagehosting.net/dydat

    So currently I'm unable to use it...
    Secondarily, I'd be glad to see Coffeescript among the supported language (AFAIK there's no syntax highlighters that support it yet).
    Thanks in advance for your help

    Davide

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

  2. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

    I got it working here:

    http://snag.gy/TWgbH.jpg

    http://aksandbox.webege.com/?p=107

    I suspect this is theme related, or where you're attempting to show the Crayon. Those settings are fine.

  3. unDavide
    Member
    Posted 1 year ago #

    Thanks for the answer - latest update is working (I don't know where the issue was, in the theme or plugin - but I'm fine now ;-)
    Thanks

    Davide

  4. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome!

  5. unDavide
    Member
    Posted 1 year ago #

    Actually, I'm afraid I've to revise my statement - there's a workaround that... works.

    Basically, the problem keeps showing, but: if I activate another syntax highlighter WP plugin, publish my post, then revert to (that is, activate again) Crayon... everything is fine. Go figure!

    Thanks
    Davide

    PS
    That said, the CoffeeScript feature request is still valid :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.