WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: CP Import] Tips and Tricks: Avoiding script time-out (3 posts)

  1. John Luetke
    Member
    Posted 5 years ago #

    CP Import will time-out (suddenly stop importing) when it reaches PHP's max_execution_time, but has not finished. There are 2 ways to fix this:

    1. If you have access to edit your php.ini, it is recommended that you increase the value of max_execution_time to 900 (15 minutes).
    2. If not, you will need to split your archive into chunks smaller than the initial suggestion of 1000 articles.

    The cause of CP Import timing out is related to the number of media attachments that you have associated with each article in the batch you are trying to import. Articles with large numbers of media attachments take longer to import, and thus the max_execution_time limit is reached before all the article in the current batch can be imported.

  2. John Luetke
    Member
    Posted 5 years ago #

    Another cause for CP Import to suddenly stop importing is that PHP memory_limit was reached. While this is a highly unlikely case, and far less probable than the max_execution_time limit being reached, it mat occur.

  3. nphoffman
    Member
    Posted 4 years ago #

    You may need to tweak your web server's config in addition to increasing the "max_execution_time" setting within php.ini .

    I just imported a blog with >1500 posts, and tons of images, into another blog. I wrote about how I solved the timeout problem.

    Cheers,
    Nick
    SoftCom Inc.
    http://softcom.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags