WordPress.org

Ready to get started?Download WordPress

Forums

Atom Publishing Protocol
[resolved] Plugin could not be activated because it triggered a fatal error. (8 posts)

  1. Saiful Islam
    Member
    Posted 1 year ago #

    Hi,
    I'm receiving a fatal error when activating the plugin.
    It is saying that "Fatal error: Cannot redeclare class wp_atom_server in /home/xxxx/public_html/bn/wp-content/plugins/atom-publishing-protocol/class-wp-atom-server.php on line 10"

    I'm using a theme from http://digitalnature.eu/themes/mystique
    It was fine till wordpress 3.4.2 but 3.5.

    My site address: http://bn.saifulislam.info
    Comment function is not working well. to see the issue please visit any post.

    Any help will be greatly appreciate.

    http://wordpress.org/extend/plugins/atom-publishing-protocol/

  2. seezee
    Member
    Posted 1 year ago #

    Same error. I installed this because support for Atom publishing was removed from core in WP 3.5.

  3. Scott Taylor
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    Saiful Islam - my guess is that they are loading the Atom class without calling require_once. If they use require or include, it will be a fatal error.

    seezee, is wp-app.php still in your codebase? It should have been removed in the upgrade process...

  4. Saiful Islam
    Member
    Posted 1 year ago #

    Thank you Scott for your reply. I just found solution for my theme a while ago.
    It looks that i don't need to use this plugin anymore :)

    Anybody who is using Mystique theme by Digitalnature can see there http://digitalnature.eu/topic/mystique-3-3-2-and-wordpress-3-5/page/2/#post-5820 for solution.

  5. Marko Heijnen
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Scott, I should have thought about that. They forgot to remove the file and that will be fixed in 3.5.1. See http://core.trac.wordpress.org/ticket/22855.

  6. Scott Taylor
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    I also just updated the plugin, turns out wp-app.php was not removed in 3.5, on deck to be removed in 3.5.1: https://core.trac.wordpress.org/ticket/22855

    http://plugins.trac.wordpress.org/log/atom-publishing-protocol

  7. seezee
    Member
    Posted 1 year ago #

    wp-app.php is not in the codebase. I've deleted the plugin, since it appears xml-rpc is enabled by default, but you probably still need to look into this.

  8. seezee
    Member
    Posted 1 year ago #

    FYI, my download of 3.5 did not include wp-app.php.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic