WordPress.org

Ready to get started?Download WordPress

Forums

Plugin could not be activated because it triggered a fatal error. (7 posts)

  1. laltoofan
    Member
    Posted 2 years ago #

    Hello,

    I recently tried to install a few plugins on this website http://www.andrewpikeresearch.com each time I try to activate the plugin I get this message at the top of the page.

    Plugin could not be activated because it triggered a fatal error.

    Plugins I tried to install are All in One SEO and Google Analytics for WordPress. I use a free hosting account to host this WordPress (http://byethost.com/). Each plugin was uploaded via FTP.

    I have no idea what this means, especially as I recently activated clicky plugin it seems strange that now others just will not work.

    Any help would be greatly appreciated!

  2. Brad Markle
    Member
    Posted 2 years ago #

    Hi laltoofan, the error message you may be receiving could be due to your host running older versions of PHP. I found a user with a similar issue and that was there problem:

    Fixing "Plugin could not be activated because it triggered a fatal error" (7 posts)

    After installing a couple of new plugins and getting the dreaded "Plugin could not be activated because it triggered a fatal error" message, I discovered that the plugins work under PHP 5, but not under PHP 4.

    If you get this error, check your host to see what version of PHP you're running. On my host, I can choose between PHP 4 and PHP 5 on a domain by domain basis. This may not solve all of your plugin problems, but switching to PHP 5 worked for me.

    It's also a strong possibility that the plugin(s) was coded for a previous version of WordPress and makes program calls that are no longer supported in the latest versions. It's always best to check to see if plugins have been updated, some of the database sites for plugins have very old or out of date versions up.

  3. laltoofan
    Member
    Posted 2 years ago #

    Thank you very much, I will check with the hosting company, they may actually be using an older php because it is a free account so I may have to upgrade and start paying! :( I will find out though.

  4. bookshield
    Member
    Posted 1 year ago #

    I recently have this kind of problem too. Before installing other new plug in, I still can use them. But after I installed opera shared button but I can't use dynamic side bar and Facebook, Twitter, Google Plus One social share buttons for WordPress. I'm using php5.4.3

  5. andrew wase
    Member
    Posted 1 year ago #

    I am also facing the same problem I had used NextGen gallery in my other sites but now I am not able to use the same plugin or other plugin after getting updated to WordPress 3.4.1 version in one of my site..
    it is showing

    Parse error: syntax error, unexpected T_STRING in /wp-admin/includes/upgrade.php on line 1771

    Thanks for any help in advance

  6. akabra2k2
    Member
    Posted 1 year ago #


  7. akabra2k2
    Member
    Posted 1 year ago #

    Hi guys
    You can go for http://www.hi-techwebmaster.com for web hosting as they are reliable, provide 24x7 support and most interestingly they offer 1Gb Web hosting in just Rs.400/year.

    @laltoofan: I don't think we should now go for free hosting when we could get premium hosting at such low cost. What do you say?

Topic Closed

This topic has been closed to new replies.

About this Topic