WordPress.org

Ready to get started?Download WordPress

Forums

Cool Video Gallery
[resolved] Fatal Error When Uploading Youtube video (14 posts)

  1. vmcleod
    Member
    Posted 2 years ago #

    Trying to upload youtube video into gallery and I get this message. I have other youtube videos in the gallery. The video I am trying to upload is http://www.youtube.com/watch?v=0Hzl_W1HGaI

    Fatal error: Call to a member function children() on a non-object in /home4/vmcleodl/public_html/wp-content/plugins/cool-video-gallery/lib/youtube.php on line 39

    http://wordpress.org/extend/plugins/cool-video-gallery/

  2. james85
    Member
    Posted 2 years ago #

    Let is know what exactly you typed in the box?

  3. vmcleod
    Member
    Posted 2 years ago #

    The same thing I listed in my original post:
    http://www.youtube.com/watch?v=0Hzl_W1HGaI

  4. Praveen Rajan
    Member
    Plugin Author

    Posted 2 years ago #

    @ vmcleod

    Please use your Video ID instead. 0Hzl_W1HGaI

  5. vmcleod
    Member
    Posted 2 years ago #

    That worked. FYI, the description indicates to use the entire url.

  6. velocista3
    Member
    Posted 1 year ago #

    Hi,

    There doesn't seem to be any Japanese language support for the plugin. When adding Japanese titles and descriptions the results are displayed as a series of ????? Is there a workround or any plans to support additional languages? Thanks

  7. hmodzel
    Member
    Posted 1 year ago #

    I have similar problem:

    Fatal error: Call to a member function attributes() on a non-object in /home/bluesfan/public_html/wp-content/plugins/cool-video-gallery/lib/youtube.php on line 44

    That's happen all time when I tried to put video ID what you said: 0Hzl_W1HGaI.
    That's working but only after several attempts.

    How to fix it?

  8. 3dgreek
    Member
    Posted 1 year ago #

    same:

    Warning: simplexml_load_file(http://gdata.youtube.com/feeds/api/videos/I4kczB1DjjI&) [function.simplexml-load-file]: failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request in /home/seoforbu/public_html/testbed22/wp-content/plugins/cool-video-gallery/lib/youtube.php on line 110

    Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/videos/I4kczB1DjjI&" in /home/seoforbu/public_html/testbed22/wp-content/plugins/cool-video-gallery/lib/youtube.php on line 110

    Fatal error: Call to a member function children() on a non-object in /home/seoforbu/public_html/testbed22/wp-content/plugins/cool-video-gallery/lib/youtube.php on line 39

    Works flawlessly on another site

  9. Praveen Rajan
    Member
    Plugin Author

    Posted 1 year ago #

    @ 3dgreek

    Your video ID is I4kczB1DjjI. Please provide valid Video ID when adding to gallery.

    http://www.youtube.com/watch?v=I4kczB1DjjI

    Thanks,
    Praveen Rajan

  10. tom@thelatest.co.uk
    Member
    Posted 1 year ago #

    I'm getting this error...

    Fatal error: Call to undefined function bcmod() in /home/thelatestv2/htdocs/wp-content/plugins/cool-video-gallery/lib/core.php on line 1255

    please help :D

  11. bbrunning
    Member
    Posted 1 year ago #

    Tom:
    I found a fix, in core.php replace the 2 instances of bcmod with fmod. Worked like a charm for me. Centos 64bit

  12. rlaanemets
    Member
    Posted 1 year ago #

    I hit the same problem as tom@thelatest.co.uk and bbrunning. Please modify the core not require the bcmath extension. It's impossible to get it installed on cheap shared hostings.

  13. Praveen Rajan
    Member
    Plugin Author

    Posted 1 year ago #

  14. marion2999
    Member
    Posted 1 year ago #

    Hello,
    sorry to dig the subject... But could it be a chmod problem?
    It was not working for me neither (I mean I had this "Fatal error... children" problem), although I have SimpleXML : Activated / allow_url_fopen : Enabled / video ID and not URL.
    All I did was to change chmod on the plugin folder and now it works.
    But it may also break next time I upload a video, I don't know... :-/

    Anyway, thanks for your plugin, i's cool when it works ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic