WordPress.org

Ready to get started?Download WordPress

Forums

Cool Video Gallery
[resolved] A couple fixes for Linux installs (3 posts)

  1. bbrunning
    Member
    Posted 1 year ago #

    #1: FFMPEG not installed even when it is, make sure you change the directory (if using linux) to the proper installation section. Mine was /usr/lib/ffmpeg
    After that, I had to edit /lib/core.php in thplugin directory and change the following lines of code:

    function ffmpegcommandExists() {
    $options = get_option('cvg_settings');
    $command = escapeshellarg($options['cvg_ffmpegpath']);
    exec($command, $output, $return);
    /**
    if(is_array($output) && !empty($output)) {
    return true;
    }
    */
    if ($return <= 1) {
    return true;
    }
    return false;
    }

    #2: If you get the error when uploading youtube videos about the bcmod function. Changed core.php from bcmod to fmod

    always remember to use your Video ID, not the entire URL.

    Also, I take no credit for the above solutions, I found them around the net on wordpress forums and linux forums.

    http://wordpress.org/extend/plugins/cool-video-gallery/

  2. Praveen Rajan
    Member
    Plugin Author

    Posted 1 year ago #

    @ bbrunning

    Appreciate your help.

    Regards,
    Praveen Rajan

  3. arjay1
    Member
    Posted 1 year ago #

    I am running cool video Gallery in WP 3.5.1 on a Linux system (debian).

    I have tried the above suggestions and they don't appear to work. Still getting the message that ffmpeg is not installed (when it is). It is installed in /usr/bin/ffmpeg

    I have changed the setting in CVG to this. Also edited the core.php file as per above post. I am presuming that you add the commented part above:
    /**
    if(is_array($output) && !empty($output)) {
    return true;
    }
    */

    (uncommented of course!)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic