WordPress.org

Ready to get started?Download WordPress

Forums

Cookillian
[resolved] Clashes with WP-Topbar (11 posts)

  1. AWOL
    Member
    Posted 2 years ago #

    This is a good plugin but unfortunately it means another good plugin, WP-Top Bar, stops working when it is activated. I have tried clicking the 'Required' box next to the cookie generated by the plugin but that doesn't do anything. I can't tell you any more than that really - anyone have any ideas?

    http://wordpress.org/extend/plugins/cookillian/

  2. AWOL
    Member
    Posted 2 years ago #

    I have just tried it with another notification plugin - Easy Heads Up Bar - and it also prevents that working, so I'm not sure if this is something that can be fixed.

  3. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    If it is WP-TopBar by Bob Goetz, I've checked it against Cookillian 1.1.7 and both appear to be working as it should.

    Is there anything specific that you try to display with WP-TopBar, which might be interfering?

  4. AWOL
    Member
    Posted 2 years ago #

    Yes, that is the plugin, and no, I just display a line of text which links to a download on MediaFire. As stated above, I have also tried another plugin which does essentially the same thing and get the same problem. Neither will display when the Cookillian plugin is activated. Is there something I need to do in the settings?

  5. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    There shouldn't be any need to do something specific, no. Is there a URL where I check why this is happening for you?

  6. AWOL
    Member
    Posted 2 years ago #

    My site is at http://www.awolonline.net but I have your plugin deactivated currently as I need the top bar displayed. I have not yet updated to the latest WP version (I am on the one before) but I don't think that would make any difference would it? I am using the Suffusion theme incidentally so maybe there is some sort of conflict with that?

  7. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Just a heads up, with the report of another user I may have found a bug, which I'll resolve ASAP.

  8. AWOL
    Member
    Posted 2 years ago #

    OK, thanks , appreciate your efforts.

  9. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi!

    Hopefully version 1.1.13 will solve the problem you were experiencing. Let me know if that's the case or if the issue persists. Thank you for you patience!

  10. AWOL
    Member
    Posted 2 years ago #

    Hi and thanks for addressing this. Whatever you did seems to have done the trick as far as the Top Bar plugin goes, but I am finding it a little difficult to see whether the plugin is working properly otherwise, as even though I have activated my location in the settings and cleared my cookies, I don't see the message appear. When I check the statistics it is telling me that people from various locations, including mine, have seen the alert etc but I would like to be able to see it myself. Can you suggest any reason why it is not showing for me? Alternatively is there any way a preview can be displayed for people who are not in a location where the cookie law is in force?
    Many thanks.

  11. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi!

    The alert will not be displayed if you're logged in to WordPress (to prevent it from breaking WordPress/lose access to the Admin area). However, if you enable the Debug Mode (found under Advanced Settings), you can see what the message looks like (it will continue to work as usual for visitors that have not logged in). You should only use the Debug Mode temporarily though.

    Also, on the Settings screen, you will find a Debug link, which expands an area with more details about your server, including the IP address you're connecting from and detected location - if these details are incorrect, you may need to select a different GeoIP provider (ie., MaxMind).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic