WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Cookies for Comments] everything going to spam (6 posts)

  1. sknob
    Member
    Posted 5 years ago #

    Hello and thanks for the plug-in.

    I've been testing it along (but not simultaneously) with wp-spamfree and would much rather use yours (simpler is better).

    But in all my testing, legitimate comments end up in the akismet spam queue.

    Is this normal behavior or am I missing something. Tried with different versions of WP on 2 computers and an iPhone...

    Thanks for your help,

    Vincent.

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Does the browser you're testing with have a cookie from your site with a long 32 character name? Does the source code of your site have a stylesheet with that same 32 character name as the filename?

  3. sknob
    Member
    Posted 5 years ago #

    This happens on Safari 3 (Mac) and FireFox 2 (PC), on 2 separate machines and 5 different WP blogs...

    On the Mac, I can see the link to the stylesheet in my source when I activate CFC.

    I don't see a corresponding cookie in my cookies though...

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Do you have any other plugins that might conflict with the stylesheet setting the cookie?
    What do you see when you load the stylesheet in it's own window? You should see a blank page.
    When you load the stylesheet, does it set a cookie.
    Are there an errors in the error log?

    Add error_log() calls to the plugin so you know the plugin is being called. See the Php manual for how to use that command. (Google will find it)

  5. sknob
    Member
    Posted 5 years ago #

    Thanks for the tips (some are a bit over my head).

    Nevertheless, it seems the problem is that the stylesheet call is added to the page source, but the css file is not created (can't see it on my FTP and I get a 404 when I try to load it...).

    Testing on a WP 2.5.1 blog. Other active plugins are Akismet, Feedburner, SRG clean archives...

    My ISP is blocking outbound calls on port 80, which nukes Akismet, which is why I'm looking for another solution. Could that be interfering with your plugin?

  6. Donncha O Caoimh
    Member
    Posted 5 years ago #

    First thing you must do is upgrade to 2.6.5 as you're just asking to be hacked!
    Does your blog use fancy permalinks? ie. mod_rewrite?

Topic Closed

This topic has been closed to new replies.

About this Topic