WordPress.org

Ready to get started?Download WordPress

Forums

Content Warning
Version: 2.4.7 (23 posts)

  1. m4declare1
    Member
    Posted 2 years ago #

    Not working!
    Warning: include(lib/ajax.inc.php) [function.include]: failed to open stream: No such file or directory in

    Warning: include() [function.include]: Failed opening 'lib/ajax.inc.php' for inclusion (include_path='.:/usr/local/php5_3/lib/php') in

    http://wordpress.org/extend/plugins/content-warning-v2/

  2. 80bit
    Member
    Posted 2 years ago #

    Also getting the issue. Tried adding the old ajax.php into the lib folder, and renamed it to ajax.inc.php. Noob move. Doesnt work of course. :) Just posting here so i get followups.

  3. ThorsDad
    Member
    Posted 2 years ago #

    Not working here either. I've gone back to the previous version.

    This appears on the header of my site after upgrading to 2.4.7

    Warning: include(lib/ajax.inc.php) [function.include]: failed to open stream: No such file or directory in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php on line 23

    Warning: include() [function.include]: Failed opening 'lib/ajax.inc.php' for inclusion (include_path='.:/usr/local/share/pear') in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php on line 23

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php:23) in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/si-contact-form/si-contact-form.php on line 1931

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php:23) in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/si-contact-form/si-contact-form.php on line 1931

  4. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Grr... this always happens when I add a new file :( You guys will have a patch by midnight.... I don't know why it's not working but the include issue is annoying lol. Simple inclusion issue, I forgot to check the box on SVN... gahhhhh

  5. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Updated and working, sorry guys I need to get used to checking that in the SVN before I commit lol. Anyhow it's fixed and proven to work. However, I did remove some "default" values from the enter/exit texts. So you will have to go to the admin panel and add that text back.

  6. damsko
    Member
    Posted 2 years ago #

    Thanks Jerry,

    conflict is solved. Strange thing that now however happens on my configuration is that the plugin version 2.4.8 does not load. I have .htaccess password protected wp-admin folder and with new version of plugin only get the prompt for password to gain acces to the protected folder. No "warning screen" that does not seem to load without access to wp-admin.

    Any idea?

    Further only small typo 'bug' on the 'Denial' tab ;-) 'If you everY have...'

    At least you get some feedback when things do not work.

  7. m4declare1
    Member
    Posted 2 years ago #

    Thanks Jerry conflict is solved

  8. ThorsDad
    Member
    Posted 2 years ago #

    2.4.8 isn't working for me. I don't get any warning screen. Going back to 2.4.6 makes everything work fine.

  9. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Damsko:
    This may be due to the new Ajax using admin-ajax. I could be wrong but I'll look into it.

    Thor:
    I guess what I'll be doing is downloading the uploaded version to test it against the actual development version. I'll set the stable tag back to 2.4.6 until I can figure out why its so buggy. I honestly didnd change much except the new Ajax file so I'll start there first.

    Guys I sincerely appreciate all the feedback it helps more than you know.

  10. damsko
    Member
    Posted 2 years ago #

    When new version uses admin-ajax.php from wp-admin folder then that explains why i get the password prompt.

    Would it be possible not to use any files from wp-admin folder?

    I think i will not want to give up my wp-admin folder protection in order to run the content warning.

    Also back to version 2.4.6.

    Thanks for looking into it.

  11. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Damsko:
    What I meant to say was that it uses wp-admin/admin-ajax.php, still the same but just making sure we're on the same page.

    I'll have a look into a work around and see what I can do.

  12. damsko
    Member
    Posted 2 years ago #

    Hi Jerry,

    we are on same page. File is wp-admin/admin-ajax.php.

    Visitors to my site are not allowed to access that.

    When there is work around not to use anything within the wp-admin folder it would be useful for me. Then i could keep the plugin updated.

    I might also not be the only one that restricts access to wp-admin.

  13. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Yea I was thinking of that, I know I was also thinking of blocking my wp-admin with .htaccess

    [EDIT]
    Worst case, I'll still include the old ajax file and give you the option of using it or the new one in the admin panel.

  14. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Hey thor, would you care to clear your cache and see if that's the cause? I think your issue may be related to a cached version of the javascript file.

  15. ThorsDad
    Member
    Posted 2 years ago #

    @Jerry: I upgraded to 2.4.8 and cleared the cache on my browser. I now have no content warning screen. To be sure I went to a computer with a fresh install of Windows and installed Firefox for the first time. Still no content warning.

  16. m4declare1
    Member
    Posted 2 years ago #

    UPDATE: I take that back....It's NOT working! There still a BIG conflict with this update!

    (Thanks Jerry conflict is solved)

  17. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Hey thor, I ran into this with another user also. Firstly download the new 2.4.10 I just released and see if you get the dialog now. If not, well go to the support link and send me some login stuff like before and I'll have a look. I'll be home all day today and if that bug is still there, I would like to get it stomped :)

  18. ThorsDad
    Member
    Posted 2 years ago #

    @Jerry: I tried 2.4.10 on two different sites with no luck. The warning screen fails to appear. I emailed you login credentials to one of the sites. Let me know if you don't receive them.

  19. damsko
    Member
    Posted 2 years ago #

    Hi Jerry,

    i just looked at last update 2.2.4.12 and find no option to disable using wp-admin/admin-ajax.php.

    [EDIT]
    Worst case, I'll still include the old ajax file and give you the option of using it or the new one in the admin panel.

    Plugin goes straight to wp-admin/admin-ajax.php so visitors would only get password prompt on my site instead of a warning when using last version.

    Are you planning to still make a option not to use wp-admin/admin-ajax.php ?

    Greetings, damsko

  20. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Damsko,

    Sorry m8, haven't had time to use the backwards compatibility. Let me finish up with this client in the next few days and we'll get that fixed for you. I'm soooooo sorry, I was more worried about the debug popups and fixed that first.

  21. damsko
    Member
    Posted 2 years ago #

    No problem Jerry,

    version 2.4.6 works fine for me with my password protected wp-admin folder so no need to hurry for me. I just update the version number in main.php for now ;-) Perhaps that will even be enough to keep the plugin OK for the rest of my blogging life.

    But I will keep a eye on your future releases to see if you made the option not to use wp-admin/admin-ajax.php.

    Best regards, damsko

  22. Jerry
    Member
    Plugin Author

    Posted 2 years ago #

    Hey damsko,

    Found a work around for ya if you want to use the newest version, and any plugin that utilizes the admin-ajax files:

    http://wordpress.org/support/topic/plugin-content-warning-cwv2-wp-admin-protection-and-you?replies=1#post-2714782

  23. damsko
    Member
    Posted 2 years ago #

    Hi Jerry,

    i think that might solve it. Will have a try adding the:

    <Files admin-ajax.php>
    Order Allow,Deny
    Allow from All
    Satisfy Any
    </Files>

    And see if it works. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic