WordPress.org

Ready to get started?Download WordPress

Forums

Content Warning
Per post warning without site-wide? (6 posts)

  1. vinsyn
    Member
    Posted 2 years ago #

    I've tried everything possible to get this to work... We need to disable the site-wide warning dialog while enabling per-post dialog. Is this currently possible?

    Basically, we do not want every user who visits the site to immediately see a content warning. We need the warning to only appear on certain posts.

    I hope this is an easy fix and I made a mistake somewhere. Great plugin otherwise!

    Thank you.

    http://wordpress.org/extend/plugins/content-warning-v2/

  2. luckdragon
    Member
    Posted 2 years ago #

    isn't there an option in the main settings to allow override for individual posts? and also the setting for whether default for posts should be on or off?

  3. vinsyn
    Member
    Posted 2 years ago #

    Yes those settings exist and I've tried every combination of on/off.... For me it's either site-wide warning or none at all. Any ideas?

  4. luckdragon
    Member
    Posted 2 years ago #

    first off, if you tried every combination, then what probably happened is that all posts got flagged as "on" by default, set it to yes allow override and dialog disabled

    then, edit your post/page there should be an option in there to allow you to disable the warning (or enable it as the case may be), if you don't see it, remember to click the screen options pulldown and look there also

  5. vinsyn
    Member
    Posted 2 years ago #

    thanks for your help. i followed your directions and it's still not working.

    here are my config settings:
    Toggle Content Warning v2: disabled (if enabled it goes site-wide)
    Sitewide Option: disabled
    Kill Immediately?: checked
    Allow Per-Page/Post Overrides: yes
    Default for Overrides: dialog disabled
    Post setting is: enabled cw dialog

    the only way the dialog shows up is if i enable sitewide option and then it's only on the main page.

    any ideas on what's going on?

    Thanks

  6. vinsyn
    Member
    Posted 2 years ago #

    SOLVED!

    It seems I've encountered a bug. The site-wide protection is automatically switched on when the most recent post is 'enabled'. As long as the most recent post is 'disabled' it works as expected.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.