WordPress.org

Ready to get started?Download WordPress

Forums

Content Scheduler
Fixed plugin not working 3.4.2 (12 posts)

  1. wobblemedia
    Member
    Posted 1 year ago #

    Hey

    I'm developing a site that is based around a plugin like this. I looked into other plugins but for some reason none of them would work for me. The more I looked into how this works the more I noticed the word 'cron' coming up.

    If you are using a linux server, there is a file in your root directory called .htaccess (the dot makes it hidden, so google how to show it). In there add the following to the end of the code.

    <Files wp-cron.php>
    allow from all
    Satisfy Any
    </Files>
    # END WordPress

    If you are using a Windows server, the file is called mod_access(I think).

    When I made this change, the plugin which was previously unresponsive worked perfectly with every feature that was advertised. This feature of the site literally was a make or break thing for my client. So I thought I would share it encase anyone else is in the same boat!

    I would hope that someone with a bit more knowledge relating to .htaccess files and the code above would advise to security issues that may arise from using it and possibly offer an alternative? For now, use it at your own risk!

    Anyways, I hope this has helped anyone that might be stuck with this plugin.

    Cheers

    http://wordpress.org/extend/plugins/content-scheduler/

  2. eyephone21
    Member
    Posted 1 year ago #

    Wow! it seems to work!
    I've tried at least 3 plugins that rely on this cron thing and none worked. Now with this code in .htaccess this plugin (the best of these i've tried, as features) works! So far i've tried only to delete article after expiration, now i'm gonna try more options..

    thanks for sharing, Wobblemedia!

  3. quintain
    Member
    Posted 1 year ago #

    Hi
    I cannot get any cron to work either so thank you for your advice.
    However when I opened up my .htaccess file it already finishes with
    # END WordPress

    Should I leave that line out of your code ??

    (I'm trying not to screw things up to much hence my question)

  4. eyephone21
    Member
    Posted 1 year ago #

    Hi quintain.
    First make a backup of the .htaccess file!

    the file must have only one # END WordPress, so it's safe to leave that line out.
    Anyway i think that lines that starts with # are comments, so probably i doesn't really matter...

  5. quintain
    Member
    Posted 1 year ago #

    Hi eyephone21

    Thank you for your reply.
    I have carried out the procedures but still no selected post is deleting on my underused site http://www.floodproblems.co.uk

    I will persevere but if you or any one else have any ideas I would welcome them.

    I am visiting the site while waiting for the delete time to arrive to kick start the cron procedure.

    BTW I have double++ checked about enabling the plugin in each test post and I have set it to 'delete' in the options and saved.

    I have set the content-scheduler.php to 755 in cpanel.

    AND I have quietly swore at everything, which frequently seems to help!!!

    Best Regards
    quintain

  6. wobblemedia
    Member
    Posted 1 year ago #

    Eyephone21 - I'm glad it helped. Hope it works well for you!

    Quintain - The # lets you know that that code will not be executed. It's just there for 'commenting' so you can write notes letting you know what is what when your .htaccess file is full of different commands.

    In PHP this is done with // or /* */ for multiple line comments.
    In HTML This is done with <!-- this is a comment -->
    If you view this pages source you will see <!-- and --> all over it. It lets people know what they are looking at and how to better understand it.

    So in your .htaccess file, the # is there to let you know what has placed that code in there, or what it does. For this particular site that i used cron with, my .htaccess file has comments letting me know that wordpress is using this code by saying #BEGING WordPress.

    When you put in # your .htaccess file, the server will ignore anything that comes after it on that line.

    in short, you can leave the # comments out, but its good practice to leave them in.

  7. wobblemedia
    Member
    Posted 1 year ago #

    Also Quintain, I find it is best to minimize on use of plugins for wordpress sites. I know for a fact I had a few conflictions with this plugin and I would highly advise trying to hand code whatever you can.

    before you go banging your head against a brick wall(like i do), I would suggest that you disable every plugin you are using and just test out contentsheduler on its own. If it works, start enabling plugins one by one, and see if it stops working.

  8. wobblemedia
    Member
    Posted 1 year ago #

    One other thing quintain which I just noticed. You said you are visiting the site periodically to see if the expiration is working. You can simply set it to expire minutes after you've made the post to test it.

    Just sayin'

  9. sweetiespicks
    Member
    Posted 1 year ago #

    I tried adding that section to the .htaccess file and I still can't get the plugin to work at all.

    I just have the plugin set to "Match selected — Make posts exist only in selected categories." Basically, just to move the post from the original category to a category labeled expired. The post never moves or gets taken out of the original category.

    Could the problem be my Cache program? I use W3 Total Cache. I also have my site on CloudFlare.com

  10. Paul Kaiser
    Member
    Plugin Author

    Posted 1 year ago #

    @Sweetiespicks, I'll see if I can reproduce with W3TC or on CloudFlare.com. Hang in there!
    Paul

  11. Frederick Townes
    Member
    Posted 1 year ago #

    @Paul Kaiser, let me know what you find please.

  12. Paul Kaiser
    Member
    Plugin Author

    Posted 1 year ago #

    Content Scheduler uses wp-cron as a trigger to check for expirations. If you have any caching solution configured aggressively, your server (or CloudFlare CDN, etc.) could bypass WordPress for an extended period of time -- serving up cached content, as designed.

    Suggestions:
    1. Try to get Content Scheduler working on your site or a testing site that does not have any caching enabled.
    2. Consider triggering wp-cron in a more traditional, reliable way, using a proper cron job. The following article contains a lot of good info on wp-cron -- including how to use a real cron job.

    http://wp.tutsplus.com/articles/insights-into-wp-cron-an-introduction-to-scheduling-tasks-in-wordpress/

    Please let me know how it goes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic