WordPress.org

Ready to get started?Download WordPress

Forums

Content Scheduler
Does not work + issues (21 posts)

  1. kryvulena
    Member
    Posted 1 year ago #

    Hello

    I installed the plugin at a fresh WP 3.4.2 instance w/o any other plugins and gave it a try. Seems there are issues and it doesn't work as it should.

    1. I have set expiration frequency to 5 minutes and posts are supposed to go "private" after expiration and to be assigned to category "expired". Does not work - once the expiration time is reached - nothing happens - posts stay published as they were. I tried to change the expiration frequency to different intervals, also "draft" instead of "private" - no matter - does not work.

    2. I've set options to notify admin/author upon expiration via email. Everytime I save settings, I receive email notifications over and over for posts that were supposed to expire (but they didn't). Even I delete those posts permanently (from trash), notifications keep on coming each time I save plugin's settings - no matter I change something in settings or not. I even deactivated and deleted the plugin and installed it one more time. It remembers deleted posts' notifications anyway - each time I save options - emails keep on coming.

    3. I also noticed that if I didn't use the email notification initially, and then turned it on, it also applied to previous posts that never used it. And notifications come once options saved...

    Is there any way to fix it?

    http://wordpress.org/extend/plugins/content-scheduler/

  2. Handoko
    Member
    Posted 1 year ago #

    I've just posted an answer on your previous post:
    http://wordpress.org/support/topic/plugin-content-scheduler-automatic-scheduling-not-working?replies=24

    I like Content Scheduler, it obviously has more features. But because it also contains bugs, so I don't use it. I use Post Expirator and I managed to make it work as I want.

  3. kryvulena
    Member
    Posted 1 year ago #

    @Handoko Zhang

    Same issue - Post Expirator does not do anything with my posts - tried on 3 fresh WP instances :(

  4. Handoko
    Member
    Posted 1 year ago #

    Hello, I don't use Content Scheduler. But I'm using Post Expirator, I might able to help you to make Post Expirator works. If you want you can email contact me, so we can share screenshot pictures.

    For privacy reason, I don't want to expose my email address here, you can contact me via:
    http://graphicslearning.com/contact/

  5. kryvulena
    Member
    Posted 1 year ago #

    @Handoko Zhang

    thanks, just sent you a PM with my email. TNX!

  6. alettieri
    Member
    Posted 1 year ago #

    Hi Folks.

    Another thing to note are your WordPress timezone settings. Under Settings > General.

    Setting a proper timezone did the trick for me.

  7. kryvulena
    Member
    Posted 1 year ago #

    I have set the right time zone at the very beginning of my WP setup. Does not work anyway :(

  8. alettieri
    Member
    Posted 1 year ago #

    @kryvulena. When you uninstalled the plugin, was the 'Remove all Content Scheduler data upon uninstall' radio button set to 'Remove all data' ?

  9. kryvulena
    Member
    Posted 1 year ago #

    I installed it 3 times at 3 separate fresh WP 3.4.2 instances. I didn't uninstall it.

  10. alettieri
    Member
    Posted 1 year ago #

    @kryvulena. Hmm. Have you tried testing one setting at a time?

  11. kryvulena
    Member
    Posted 1 year ago #

    Not sure what you mean. I tried different time/interval variants. There WP instances are on separate servers - not related to each other. I first thought it's an issue related to one of the servers, but it isn't

  12. alettieri
    Member
    Posted 1 year ago #

    I was thinking process of elimination.

    I meant to say, have the plugin only apply one setting first. For example, set it to only set your post status to 'Private' and not switch the categories or sticky setting.

    Something like:

    • Change status to: Private
    • Change stickiness to: No Change
    • Apply Category changes as: No Change
  13. kryvulena
    Member
    Posted 1 year ago #

    Ah yes, I did so... no result :(

  14. alettieri
    Member
    Posted 1 year ago #

    @kryvulena. And you're going to each post that you want to expire and switched the 'Content Scheduler' setting to 'Enable' ?

  15. kryvulena
    Member
    Posted 1 year ago #

    Yes, of course. I also tried different expiration frequency from 1 minute to 60 or so.

  16. alettieri
    Member
    Posted 1 year ago #

    Hmm.... Try enabling the WP_Debug flag in your wp-config file. Then open the Content Scheduler settings page. You should see a Table of scheduled tasks (Cron Events Scheduled). This may help verify if the scheduler is set to run cron tasks.

  17. kryvulena
    Member
    Posted 1 year ago #

    How do I enable it? Never did it before. Thanks for your willingness to help!

  18. kryvulena
    Member
    Posted 1 year ago #

    ok found it setting false to true at define('WP_DEBUG', false);

  19. alettieri
    Member
    Posted 1 year ago #

    Go to the root directory (where wordpress is installed). Find the wp-config.php file.

    There should be a setting like: define('WP_DEBUG', false);
    Change it to: define('WP_DEBUG', true);

    Also, add this line : define('WP_DEBUG_DISPLAY', false); Keeps warnings and errors off your screen.

  20. kryvulena
    Member
    Posted 1 year ago #

    Ok I did so, I also manually uninstalled the plugin and manually deleted any its data at db. Then reinstalled and set up a post to expire with 6min expiration frequency.

    Cron events schedule says:

    Oct 6, 2012 @ 5:42	 Twice Daily	wp_version_check
    Oct 6, 2012 @ 5:42	 Twice Daily	wp_update_plugins
    Oct 6, 2012 @ 5:42	 Twice Daily	wp_update_themes
    Oct 6, 2012 @ 17:42	 Once Daily	wp_scheduled_delete
    Oct 6, 2012 @ 17:42	 Once Daily	wp_scheduled_auto_draft_delete
    Oct 7, 2012 @ 14:08	 One-time	do_pings
    Oct 10, 2012 @ 22:14	 CS User Configured	content_scheduler
    Oct 10, 2012 @ 22:14	 Once Hourly	content_scheduler_notify
  21. kryvulena
    Member
    Posted 1 year ago #

    MYSTERY UNVEILED!

    I found the reason the plugin could not run its cron.

    I used to use a .htaccess file to restrict accessibility to /plugins content. The restriction was too strong and it seems the cron could not check values saved or something.

    So guys another hint what to do if your cron fails :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.