WordPress.org

Ready to get started?Download WordPress

Forums

Content Aware Sidebars
[resolved] Warning: array_flip() [function.array-flip]: (4 posts)

  1. oudein
    Member
    Posted 2 years ago #

    Warning: array_flip() [function.array-flip]: Can only flip STRING and INTEGER values! in /wp-content/plugins/content-aware-sidebars/content-aware-sidebars.php on line 211

    Fresh install of Version 0.6.1 on WordPress 3.2.1. Looking through it now, but a bit wary of changing the 'taxonomy' term value type.

    http://wordpress.org/extend/plugins/content-aware-sidebars/

  2. Joachim Jensen (Intox Studio)
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the feedback. I am aware of this error that are triggered in some cases, and it will be fixed in the next release.

    If you want to solve the problem yourself, replace all instances of array_flip with array_keys. I'm not really sure why I didn't use that function from the start.

    I might as well do a quick 0.6.2 release for this fix and not push it to 0.7.

  3. oudein
    Member
    Posted 2 years ago #

    Joachim, thanks very much for the rapid response! I have made the change and, although I don't have time right now to fully test all the functionality, I am not getting the error message.

    Thanks again! Very impressive attention!

  4. Joachim Jensen (Intox Studio)
    Member
    Plugin Author

    Posted 2 years ago #

    Always glad to help. A new version is now out, eliminating the error once and for all for everyone affected.

    I hope you will get good use of the plugin. If you run into any other problems or have any questions, feel free to write again.

    And don't forget to rate the plugin :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic