WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Validation errors occurred. (16 posts)

  1. m30ndo
    Member
    Posted 1 year ago #

    I keep getting this ERROR.

    "Validation errors occurred. Please confirm the fields and submit it again."

    Here is the FORM, I have done.

    <p>Your Name (required)
    [text* your-name] </p>

    <p>Your Phone Number (required)
    [text* your-number] </p>

    <p>Your Email Address (required)
    [email* Email] </p>

    <p>Pref.Time (required)
    [select* Pref.Time "ASAP" "Daytime" "Evening 6-8pm"]</p>

    <p>Pref.Method (required)
    [select* Pref.Method "Telephone" "Email" "SMS"]</p>

    <p>Your Enquiry (required)
    [textarea* YourEnquiry]</p>

    <p>[submit "Send"]</p>

    PLease help I have spent hours and cannot understand the problem?

    Thank you.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Can I check the site?

  3. m30ndo
    Member
    Posted 1 year ago #

    yeah sure thank you. http://www.briantcomms.co.uk : )

  4. precogtyrant
    Member
    Posted 1 year ago #

    has this issue been solved? I am having the same issue don't know where it came from.

    I had installed the dynamic text extension plugin for contact form 7... maybe it is the culprit?

  5. m30ndo
    Member
    Posted 1 year ago #

    No NOT solved pulling my hair out.. : (

  6. john99999
    Member
    Posted 1 year ago #

    MINE TOO

    but only on forms with added fields - happened right after updated to wordpress 3.4.2 ????

    ALL fields are coming up required

  7. m30ndo
    Member
    Posted 1 year ago #

    Is there any one that can help with this. Its driving me mad. Or is there a good alternative? Thanks..

  8. m30ndo
    Member
    Posted 1 year ago #

    Takayuki Miyoshi, any feedback now you have seen the site ?

  9. charkins
    Member
    Posted 1 year ago #

    This is happening to me too - altho I'm on WP 3.4.1.

    The form has been working flawlessly until now the client almost lost a hot lead (they ultimately used Facebook to contact them...)

    Very simple form: Name, Phone, Email, City, Project. The only field I required is email, but it seems to "secretly" require the phone number now as well, and an empty red box appears along with the yellow box saying "Validation errors occurred. Please confirm the required fields and submit it again."

    http://www.ciprianiremodelingsolutions.com

    Any thoughts Takayuki Miyoshi? Thank you.

  10. m30ndo
    Member
    Posted 1 year ago #

    Hi guys, I have no feedback from Takayuki, so have had to make other arrangements as the website was live and like 'charkins' mentioned there was potential loss of leads.

    I am now using a new WordPress Form Plugin called : 'Easy Contact Forms' which is fantastic and IMO far better than 'Contact Form 7', would strongly suggest having a look at that one.

    Hope this helps.

  11. charkins
    Member
    Posted 1 year ago #

    Thanks for your suggestion. Did you purchase the Pro version - was it easy to style (CSS)?

  12. @wealthcop
    Member
    Posted 1 year ago #

    I don't think it's the form. I think WordPress 3.4.2 (and maybe even the version before) broke something.

    I was using a different plugin and there was a similar problem. My CSS dude wrote, "it's coming from something called "Fast Secure Contact Form", it's also adding the form twice from one short code which leads me to think there is a problem with the plugin, maybe send them an email to see if they are aware of this kind of issue."

    Well, I just switched to another form generator (Quform - WordPress Form Builder). Same thing. Short code generates two forms on the same page (see sad http://wealthcop.com/contact-us/), and "/> was added to the top item on the left navigation menu.

    Same result, two different plugins. I think WP broke them.

  13. remzizaimi
    Member
    Posted 1 year ago #

    You need to remove the '*' from the input [text* your-name] because the star means is required.

    I hope this will help you.

  14. charkins
    Member
    Posted 1 year ago #

    I can't answer for anyone else, but I can tell you for certain that there was no "*" in the email input line, but the form still required it.

    In my case, the form had been working as expected for a long time. Then I updated the plugin, and the form broke.

  15. remzizaimi
    Member
    Posted 1 year ago #

    Well if you have still this issue, copy the code from the contact form 7 and post it here. I am using the latest contact form 7 plugin and works excellent!

  16. charkins
    Member
    Posted 1 year ago #

    I think there may be a conflict between this plugin and some other plugin we are using. It didn't exist until we updated... The plugin used to work very well, and it works well on other sites I have. Just a problem with this one. I have not had the opportunity to troubleshoot the plugin combinations with the live site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic